I cannot build my app on using LXD for risc-v

I have risc-v board and I want to build my application for snapcraft but after I installed lxd and configure it the following error appear:

I have topic about the issue on linuxcontainers forum https://discuss.linuxcontainers.org/t/no-risc-v-images-for-lxd/13694

We need images from CPC (image building team) available on simplestreams for this to work. For now you can create a container and run it with --destructive-mode

images: is not provided by Ubuntu.

Official Ubuntu images are provided from ubuntu: and ubuntu-daily: remotes.

Can you try

$ lxc launch ubuntu:focal

and let us know if that works for you?

Also have you completed LXD setup?

What is the output from

sudo lxd init


It might be that snapcraft notices that lxd cannot launch any images.

Can you confirm that the base is set to core20 in snapcraft.yaml?

application base is core20

I already setup correctly and I only found Ubuntu 21.10 for risc-v

I tried it yesterday and same error message, I will try it again

lxc launch ubuntu:focal