How to use ffmpeg from snap?

Hi, Recently I added to my app feature to search similar videos which use ffmpeg.
The problem is that snap don’t find system installation of ffmpeg(sandboxing of course).

I don’t want to bundle ffmpeg with app(not sure if this even possible, but I found The FFmpeg integration stage snaps), because my app is MIT licensed and ffmpeg use various gpl like licenses for each codec.

Is there any way to allow find by app ffmpeg and ffprobe from installed OS package(or PATH)?

To test, it is required to run this command

sudo snap install czkawka --edge

and next go at left side to “Similar Videos” tab and click Search at bottom at left side.
Error like

Cannot find proper installation of FFmpeg.

should be shown

You cannot access system installed ffmpeg from snap confinement. Either ship ffmpeg with snap or follow the guide you linked in the original post.

Could this be an option? Using chromium-ffmpeg in third-party browser snaps

How can I integrate with ffmpeg(I don’t know how stable is chromium-ffmpeg)?
I tried to use stage-snap or something similar, but still it not worked.
Should I use plugs?

Check out this snapcraft.yaml of obs-studio. Snapcraft.yaml:

This should give you some idea of integrating ffmpeg into your snap.

OBS-Studio is GPL licensed, so they can use most of ffmpeg codecs directly, but my app is MIT licensed.
That is why I want to use instead manually downloading source code and compiling it.