How to uninstall snapd and snaps? (so I can start fresh)

I am a new Debian user and recently attempted to install snapd and so far one snap on my system. Unfortunately, things are not working properly, and because of my clumsy attempt I’m not sure where to start in terms of troubleshooting. I think my best bet is to uninstall everything snap-related and then reinstall, (following the directions fully this time!)

What is the best way to do this?

Can you describe what not working properly means in your case? The snaps cannot be installed? The apps don’t start? Apps start but crash?

@mborzecki, I cannot launch the app. I have tried it a few ways:

  1. It does not appear in my application menu.

  2. I cannot launch it from the terminal. I get a response saying the program does not exist.

  3. The file manager does not recognize it as an executable program either. (If I’ve even found the right file. I found what appears to be a symlink to the app.)

I’m still a novice, so please bear with me if it seems I’m overlooking obvious details!

I did try rebooting the system, but nothing changed.

if you freshly installed snapd, you need to log out and back in again once so your desktop can pick up the new additional location for launchers … that should fix 1) …

snap packages put all their binaries into /snap/bin … which gets added to your PATH when installing snapd to your system … but again this only takes affect when you once log out and back in due to the way the PATH variable is handled in linux … (this should help with 2)

@ogra, thank you for the idea. Sadly, I have already tried logging out and back in, and the problem persists.

what kind of desktop do you use over there ? all desktop environments following the freedesktop standard should actually work … (though the PATH setting is independent of that but should be supported by all current login managers)

I’m using the Cinnamon desktop environment.