How to run kubeadm cluster using snap

I have used snap classic to install version 1.23.17 of kubeadm ,kubelet and kubectl but when i do kubeadm init it gives error

root@master-hm:~/kubernetes/_output# kubeadm init I0326 07:42:54.574303 805380 version.go:256] remote version is much newer: v1.29.3; falling back to: stable-1.23 [init] Using Kubernetes version: v1.23.17 [preflight] Running pre-flight checks [WARNING Service-Kubelet]: kubelet service is not enabled, please run ‘systemctl enable kubelet.service’ error execution phase preflight: [preflight] Some fatal errors occurred: [ERROR Port-10250]: Port 10250 is in use [preflight] If you know what you are doing, you can make a check non-fatal with --ignore-preflight-errors=... To see the stack trace of this error execute with --v=5 or higher

Hi ! @hritvikmathur .

Perhaps you must active the service linked to the snap kubeadm.

Try this to see :

systemctl enable kubelet.service

I have tried this but this gives error no service found because snap save the service at some other location and is not maapeed

Do you know the location in question ?

no i have no clue how to setup kubeadm cluster using snap

please help

i have to use kubernetes version 1.23.17 and its not available in kubernetes repo so i used snap

have you checked the documentation that is linked in the output of snap info kubeadm it seems to be pretty excessively describing all that stuff …

Okay, @hritvikmathur .

  1. Make sure you have these packages kubelet , kubeadm.

    You can install them via these commands :

    sudo snap install kubelet --classic

    sudo snap install kubeadm --classic

  2. Then active the service kubelet .

    You can active the service by executing this command :

    sudo snap start kubelet

  3. Finally

    sudo kubeadm init