How to fix snap binaries not found

Warning: /snap/bin was not found in your $PATH. If you’ve not restarted
your session since you installed snapd, try doing that. Please
see How to fix snap binaries not found for more details.

snap version

snap 2.42.4
snapd 2.42.4
series 16
kali 2019.4
kernel 5.3.0-kali2-amd64

/etc/os-release

PRETTY_NAME=“Kali GNU/Linux Rolling”
NAME=“Kali GNU/Linux”
ID=kali
VERSION=“2019.4”
VERSION_ID=“2019.4”
VERSION_CODENAME=“kali-rolling”
ID_LIKE=debian
ANSI_COLOR=“1;31”
HOME_URL=
SUPPORT_URL=
BUG_REPORT_URL=

Desktop, shell, etc


…,;:ccc,. h3bc1@h3bc1
…’’’;lxO. OS: Kali Linux
…’’’’…,:ld; Kernel: x86_64 Linux 5.3.0-kali2-amd64
.’;;;:::;,.x, Uptime: 18m
…’’’. 0Xxoc:,. … Packages: 2684
… ,ONkc;,;cokOdc’,. Shell: bash
. OMo ‘:ddo. Resolution: 1920x1080
dMc :OO; DE: Xfce
0M. .:o. WM: Xfwm4
;Wd WM Theme: Kali-Dark
;XO, GTK Theme: Kali-Dark [GTK2]
,d0Odlc;,… Icon Theme: Flat-Remix-Blue-Dark
…’,;:cdOOd::,. Font: Cantarell 11
.:d;.’:;. Disk: 17G / 163G (11%)
‘d, .’ CPU: AMD FX-6300 Six-Core @ 6x 3.5GHz
;l … GPU: GeForce GT 630
.o RAM: 1663MiB / 7948MiB
c
.’
.

@chipaca

I will also suggest there might be something wrong with your test. /var/lib/snapd/snap/bin is in my $PATH and there’s no issue with executing the binaries. I still get the error message during installation of all applications.

snap    2.42.2-1.fc31
snapd   2.42.2-1.fc31
series  16
fedora  31
kernel  5.3.14-300.fc31.x86_64
Warning: /snap/bin was not found in your $PATH. If you've not restarted your
     session since you installed snapd, try doing that. Please see
     https://forum.snapcraft.io/t/9469 for more details.

$ snap version
snap       2.42.4
snapd      2.42.4
series     16
linuxmint  3
kernel     4.9.0-11-amd64

The contents of /etc/os-release

PRETTY_NAME="LMDE 3 (cindy)"
NAME="LMDE"
VERSION_ID="3"
VERSION="3 (cindy)"
ID=linuxmint
ID_LIKE=debian
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.linuxmint.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=cindy
DEBIAN_CODENAME=stretch

neofetch info:

neofetch
         `.-::---..           ******@****** 
      .:++++ooooosssoo:.       ---------------- 
    .+o++::.      `.:oos+.     OS: LMDE 3 Cindy x86_64 
   :oo:.`             -+oo:    Model: Virtual Machine Hyper-V UEFI Release v1.0 
 `+o/`    .::::::-.    .++-`   Kernel: 4.9.0-11-amd64 
`/s/    .yyyyyyyyyyo:   +o-`   Uptime: 19 hours, 6 minutes 
`so     .ss       ohyo` :s-:   Packages: 1915 
`s/     .ss  h  m  myy/ /s``   Shell: bash 4.4.12 
`s:     `oo  s  m  Myy+-o:`    Resolution: 1572x886 
`oo      :+sdoohyoydyso/.      DE: Cinnamon 4.2.4 
 :o.      .:////////++:        WM: Mutter (Muffin) 
 `/++        -:::::-           WM Theme: Mint-Y-Dark (Mint-Y) 
  `++-                         Theme: Mint-Y [GTK2/3] 
   `/+-                        Icons: Mint-Y [GTK2/3] 
     .+/.                      Terminal: gnome-terminal 
       .:+-.                   CPU: Intel Xeon L5520 (3) @ 2.2GHz 
          `--.``               Memory: 1547MB / 1904MB

The problem here, at least on Raspberry pi systems running Debian, is that sudo does not pick up on paths exported from your user profile. See here for details.

The solution is to add /snap/bin to the list of paths that sudo recognises –

sudo visudo

and then add

/snap/bin/

to the line that starts

secure_paths

in that file. After that, snaps will run with sudo and without errors. Otherwise, commands like

sudo /snap/bin/nextcloud.occ

will work, but why type the extra?

snap version:
snap 2.42.5
snapd 2.42.5
series 16
debian 10
kernel 4.19.0-6-amd64

/etc/os-release:
PRETTY_NAME=“Debian GNU/Linux 10 (buster)”
NAME=“Debian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=debian
URLs removed as I cannot post three links!

bash shell

processor : 0
vendor_id : AuthenticAMD
cpu family : 21
model : 48
model name : AMD A8-7100 Radeon R5, 8 Compute Cores 4C+4G
stepping : 1
microcode : 0x6003104
cpu MHz : 1097.750
cache size : 2048 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 16
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb bpext ptsc cpb hw_pstate ssbd vmmcall fsgsbase bmi1 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold overflow_recov
bugs : fxsave_leak sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips : 3593.13
TLB size : 1536 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro [13]

processor : 1
vendor_id : AuthenticAMD
cpu family : 21
model : 48
model name : AMD A8-7100 Radeon R5, 8 Compute Cores 4C+4G
stepping : 1
microcode : 0x6003104
cpu MHz : 1097.558
cache size : 2048 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 2
apicid : 17
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb bpext ptsc cpb hw_pstate ssbd vmmcall fsgsbase bmi1 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold overflow_recov
bugs : fxsave_leak sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips : 3593.13
TLB size : 1536 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro [13]

processor : 2
vendor_id : AuthenticAMD
cpu family : 21
model : 48
model name : AMD A8-7100 Radeon R5, 8 Compute Cores 4C+4G
stepping : 1
microcode : 0x6003104
cpu MHz : 1097.676
cache size : 2048 KB
physical id : 0
siblings : 4
core id : 2
cpu cores : 2
apicid : 18
initial apicid : 2
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb bpext ptsc cpb hw_pstate ssbd vmmcall fsgsbase bmi1 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold overflow_recov
bugs : fxsave_leak sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips : 3593.13
TLB size : 1536 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro [13]

processor : 3
vendor_id : AuthenticAMD
cpu family : 21
model : 48
model name : AMD A8-7100 Radeon R5, 8 Compute Cores 4C+4G
stepping : 1
microcode : 0x6003104
cpu MHz : 1097.729
cache size : 2048 KB
physical id : 0
siblings : 4
core id : 3
cpu cores : 2
apicid : 19
initial apicid : 3
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb bpext ptsc cpb hw_pstate ssbd vmmcall fsgsbase bmi1 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold overflow_recov
bugs : fxsave_leak sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips : 3593.13
TLB size : 1536 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro [13]

Thanks in advance!

snap 2.42.5
snapd 2.42.5
series 16
debian 10
kernel 4.19.0-5-amd64

PRETTY_NAME=“Debian GNU/Linux 10 (buster)”
NAME=“Debian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=debian

GNOME 3.30

Guake Terminal

Thanks in advance!

Warning: /snap/bin was not found in your $PATH. If you’ve not restarted your session since you
installed snapd, try doing that. Please see ******************* for more
details.

PRETTY_NAME=“Deepin 15”
NAME=“Deepin”
VERSION_ID=“15.11”
VERSION=“15.11”
ID=deepin
HOME_URL=""
BUG_REPORT_URL=""

GUI Desktop is deepin desktop environment.

shell is bash

snap 2.42.5
snapd 2.42.5
series 16
deepin 15.11
kernel 4.15.0-30deepin-generic

snap 2.42.2-1.el7
snapd 2.42.2-1.el7
series 16
centos 7
kernel 3.10.0-1062.9.1.el7.x86_64

PRETTY_NAME=“Deepin 15”
NAME=“Deepin”
VERSION_ID=“15.11”
VERSION=“15.11”
ID=deepin
HOME_URL=“https://www.deepin.org/
BUG_REPORT_URL=“http://feedback.deepin.org/feedback/

snap 2.43.3-1.fc31
snapd 2.43.3-1.fc31
series 16
fedora 31
kernel 5.5.6-201.fc31.x86_64

DE: GNOME 3.34.4
Shell: bash 5.0.11

Okay so, I have a chromebook and i installed snap and hello-world does work but the apps dont?
Could i get help.

And it said this
Warning: /snap/bin was not found in your $PATH. If you’ve not restarted your session since you
installed snapd, try doing that. Please see This link for more
details.

I have the same problem. My system is SparkyLinux:

snap version:
snap 2.43.3
snapd 2.43.3
series 16
sparky 5.10
kernel 4.19.0-8-amd64

The contents of /etc/os-release:
RETTY_NAME=“SparkyLinux 5.10 (Nibiru)”
NAME=“SparkyLinux”
VERSION_ID=“5.10”
VERSION=“5.10 (Nibiru)”
ID=sparky
ID_LIKE=debian
HOME_URL=“https:/sparkylinux.org/”
SUPPORT_URL=“https:/sparkylinux.org/forum/”
BUG_REPORT_URL=“https:/sourceforge.net/p/sparkylinux/tickets”

neofetch
emag@geocomputer
. -:- ----------------
.o .-///- OS: SparkyLinux 5.10 (Nibiru) x8
oo .:/++:. Host: 2007FUG ThinkPad T60
os+ -/+++: .........``` Kernel: 4.19.0-8-amd64 /ys+`./+++/-.-::::::----...... Uptime: 24 mins
syyo++o±-::::-::/+++/- Packages: 2394 (dpkg), 3 (snap) -yyy+.+o+`:/:-:sdmmmmmmmmdy+-` Shell: bash 5.0.3 ::-` :yyy/-oo.-+/`ymho++++++oyhdmdy/` Resolution: 1400x1050 `/yy+-`.syyo`+o..o--h..osyhhddhs+//osyy/` DE: Xfce -ydhs+-oyy/.+o.-: ` ` :/::+ydhy+```-os- WM: Xfwm4 .sdddy::syo--/:. `.:dy+-ohhho ./: WM Theme: Sparky5 :yddds/:+oo+//:-`- /+ +hy+.shhy: Theme: Sparky6 [GTK2/3]
:ydmmdysooooooo-.ss/yss–oyyo Icons: ultra-flat-icons [GTK2/3]
./ossyyyyo+:-/oo:.osso- .oys Terminal: xfce4-terminal ``..-------::////.-oooo/ :so Terminal Font: Monospace 12 …----::::::::–./oooo: .o: CPU: Intel Core 2 T5600 (2) @ 1. ``````` ++o+: : GPU: AMD ATI Mobility Radeon X14
./+/- Memory: 1107MiB / 1992MiB
`-:-.
``

Hi,

Got this message, also after rebooting (even twice :slight_smile: )

My snap version :

snap 2.43.3-lp151.1.1
snapd 2.43.3-lp151.1.1
series 16
opensuse-leap 15.1
kernel 4.12.14-lp151.28.44-default

cat /usr/lib/os-release

NAME=“openSUSE Leap”
VERSION=“15.1”
ID=“opensuse-leap”
ID_LIKE=“suse opensuse”
VERSION_ID=“15.1”
PRETTY_NAME=“openSUSE Leap 15.1”
ANSI_COLOR=“0;32”
CPE_NAME=“cpe:/o:opensuse:leap:15.1”
BUG_REPORT_URL=“https://bugs.opensuse.org
HOME_URL=“https://www.opensuse.org/

So I get this message even after adding snap to the path & rebooting several times.

echo $PATH
/home/‘account’/.local/bin:/home/‘account’/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/var/lib/snapd/snap/bin:/snap/bin/

snap version
snap 2.43.3-1.el8
snapd 2.43.3-1.el8
series 16
centos 8
kernel 4.18.0-147.8.1.el8_1.x86_64

/etc/os-release
NAME=“CentOS Linux”
VERSION=“8 (Core)”
ID=“centos”
ID_LIKE=“rhel fedora”
VERSION_ID=“8”
PLATFORM_ID=“platform:el8”
PRETTY_NAME=“CentOS Linux 8 (Core)”
ANSI_COLOR=“0;31”
CPE_NAME=“cpe:/o:centos:centos:8”
HOME_URL=“https://www.centos.org/
BUG_REPORT_URL=“https://bugs.centos.org/

CENTOS_MANTISBT_PROJECT=“CentOS-8”
CENTOS_MANTISBT_PROJECT_VERSION=“8”
REDHAT_SUPPORT_PRODUCT=“centos”
REDHAT_SUPPORT_PRODUCT_VERSION=“8”

GUI
GNOME Version 3.32.2

Shell
Bash

I have Authy installed on CentOS 8 and latest Fedora. Fedora works as expected, but CentOS does not. When I install in CentOS I get

$ sudo snap install authy --beta
Warning: /var/lib/snapd/snap/bin was not found in your $PATH. If you’ve not restarted your session
since you installed snapd, try doing that. Please see How to fix snap binaries not found
for more details.

authy (beta) 1.8.0 from Authy (authy-twilio) installed
$ echo $PATH
/home/xx/.local/bin:/home/xx/bin:/usr/share/Modules/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/var/lib/snapd/snap/bin

$ snap version
snap 2.43.3-1.el8
snapd 2.43.3-1.el8
series 16
centos 8
kernel 4.18.0-187.el8.x86_64

/etc/os-release
NAME=“CentOS Linux”
VERSION=“8 (Core)”
ID=“centos”
ID_LIKE=“rhel fedora”
VERSION_ID=“8”
PLATFORM_ID=“platform:el8”
PRETTY_NAME=“CentOS Linux 8 (Core)”
ANSI_COLOR=“0;31”
CPE_NAME=“xxxx:centos:centos:8”
HOME_URL=""
BUG_REPORT_URL=""

CENTOS_MANTISBT_PROJECT=“CentOS-8”
CENTOS_MANTISBT_PROJECT_VERSION=“8”
REDHAT_SUPPORT_PRODUCT=“centos”
REDHAT_SUPPORT_PRODUCT_VERSION=“8”

OS: CentOS Linux 8 (Core) x86_64
Host: OptiPlex 9020 01
Kernel: 4.18.0-187.el8.x86_64
Uptime: 1 day, 10 hours, 4 mins
Packages: 1608 (rpm), 24 (flatpak), 6 (snap)
Shell: bash 4.4.19
Resolution: 1920x1080
Terminal: /dev/pts/0
CPU: Intel i7-4790 (8) @ 4.000GHz
GPU: Intel HD Graphics
GPU: NVIDIA GeForce GT 640
Memory: 6215MiB / 15781MiB

The install seems to have worked, I can execute Authy from the command line. Problem is, the application doesn’t show in the application folder and when it does execute it shows a “broken” icon on the panel. I am unable to add it to favorites or launch the application by any other means.

I’d appreciate any help.

$ cat /etc/os-release 
PRETTY_NAME="LMDE 4 (debbie)"
NAME="LMDE"
VERSION_ID="4"
VERSION="4 (debbie)"
ID=linuxmint
ID_LIKE=debian
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.linuxmint.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=debbie
DEBIAN_CODENAME=buster

$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/snap/bin

Had to add manually to my .bashrc, without it /snap/bin was not in path:

# Expand $PATH to include the directory where snappy applications go.
snap_bin_path="/snap/bin"
if [ -n "${PATH##*${snap_bin_path}}" -a -n "${PATH##*${snap_bin_path}:*}" ]; then
    export PATH=$PATH:${snap_bin_path}
fi

Tried in following terminal emulator: Guake, Gnome terminal (from cinnamon DE)

Getting the following error, despite having the /snap/bin in the path:

~$ sudo snap install phpstorm --classic
Warning: /snap/bin was not found in your $PATH. If you've not restarted your session since you
         installed snapd, try doing that. Please see https://forum.snapcraft.io/t/9469 for more
         details.

phpstorm 2020.1 from jetbrains✓ installed
Warning: /snap/bin was not found in your $PATH. If you've not restarted your
         session since you installed snapd, try doing that. Please see
         https://forum.snapcraft.io/t/9469 for more details.

Output of snap version:

$ snap version
snap    2.44.1
snapd   2.44.1
series  16
debian  10
kernel  4.19.0-8-amd64

Contents of etc/os-release:
(edited some links out so I can post)

NAME=“Debian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=debian
HOME_URL=“https://www.debian.org/
SUPPORT_URL=
BUG_REPORT_URL=

Desktop, shell, etc:

OS: Debian GNU/Linux 10 (buster) x86_64
Host: Aspire XC-780
Kernel: 4.19.0-8-amd64
Uptime: 15 mins
Packages: 1950 (dpkg), 4 (snap)
Shell: bash 5.0.3
Resolution: 1920x1080
WM: Xfwm4
Theme: Adwaita [GTK3]
Icons: Adwaita [GTK3]
Terminal: xfce4-terminal
Terminal Font: Monospace 12
CPU: Intel i3-7100 (4) @ 3.900GHz
GPU: NVIDIA GeForce GT 710
Memory: 1277MiB / 7936MiB

I’ve tried adding it to myu path manually with no luck, when I echo $PATH it’s there. Applications will install but they are only available via snap run <name>

$ sudo snap install --classic --candidate inkscape
Warning: /snap/bin was not found in your $PATH. If you've not restarted your session since you
         installed snapd, try doing that. Please see https://forum.snapcraft.io/t/9469 for more
         details.

Warning: flag --classic ignored for strictly confined snap inkscape

inkscape (candidate) 1.0rc1 from Inkscape Project (inkscape✓) installed
$ snap --version
snap    2.44.1-2
snapd   2.44.1-2
series  16
kali    2020.2
kernel  5.5.0-kali1-amd64                                                                                                      
$ cat /etc/os-release                                                                                       
PRETTY_NAME="Kali GNU/Linux Rolling"                                                                                           
NAME="Kali GNU/Linux"                                                                                                          
ID=kali                                                                                                                        
VERSION="2020.2"
VERSION_ID="2020.2"
VERSION_CODENAME="kali-rolling"
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="https://www.kali.org/"
SUPPORT_URL="https://forums.kali.org/"
BUG_REPORT_URL="https://bugs.kali.org/"
Warning: /snap/bin was not found in your $PATH....

snap    2.44.3
snapd   2.44.3
series  16
debian  10
kernel  5.4.28-imx6

PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian