How to create YAML for a simple Godot 3 engine project game, how to create snap?


#1

Hello, is there a simple way to pack my Godot engine application as a snap? How to do that? I need YAML example text. Which libraries to include or what to have in YAML? Which command to use in command line? Better snapcraft or better snapcraft cleanbuild? With LXD? Thanks for any info because I do not know how to package my Godot 3 engine app in Linux. No documentation anywhere about this particular topic. Because I need FUNCTIONAL snap at least for Ubuntu 18.04+ of my new 3D app to spread for free in Linux as a snap package. THANKS FOR ANY IDEAS OR HELP!


#2

I took a sample project and built/exported it as a “Linux/X11” application and build a snap as follows.

snap install snapcraft --candidate --classic

snap install multipass --beta --classic

I then made a godot_game directory and within it snap/snapcraft.yaml and gamefiles folder. Inside the gamefiles folder which contains the export of the game. Here’s the output of tree so it makes sense.

alan@hal:~/Source/godot_game$ tree
.
├── gamefiles
│   ├── Isometric Game.pck
│   └── Isometric Game.x86_64
├── isometric-game_1.0_amd64.snap
└── snap
    └── snapcraft.yaml

2 directories, 4 files

Here’s the snap/snapcraft.yaml which references the gamefiles/directory and dumps that into the snap. It also stages the minimum necessary packages.

name: isometric-game
base: core18
version: '1.0'
summary: Isometric Game
description: |
  A simple game made in Godot

grade: stable
confinement: strict

apps:
  isometric-game:
    command: desktop-launch "$SNAP/Isometric Game.x86_64"
    environment:
      LD_LIBRARY_PATH: "$LD_LIBRARY_PATH:/usr/lib/$SNAPCRAFT_ARCH_TRIPLET/pulseaudio"
    plugs:
      - opengl
      - network
      - network-bind
      - pulseaudio
      - x11
      - desktop
      - joystick

parts:
  game:
    plugin: dump
    source: gamefiles/
    after: [desktop-glib-only]
    stage-packages:
      - libgl1-mesa-dri
      - libglu1-mesa
      - libgl1-mesa-glx
      - libpulse0
      - libxcursor1
      - libxinerama1
      - libxrandr2
      - libxi6
      - libasound2
  desktop-glib-only:  
        build-packages:
          - libglib2.0-dev
        plugin: make
        source: https://github.com/ubuntu/snapcraft-desktop-helpers.git
        source-subdir: glib-only
        stage-packages:
          - libglib2.0-bin

Once all that is done just run snapcraft from within the godot_game folder and it should produce a snap which ends like this:

Priming game 
Snapping 'isometric-game' \                                                                                                                                   
Snapped isometric-game_1.0_amd64.snap

Install the snap:-

sudo snap install isometric-game_1.0_amd64.snap --dangerous

Run it with:-

isometric-game

And it should launch fine. There’s further work to do to add a desktop file and icon, but that should get you started. Let us know how you get on.


#3

artemis@artemis:~$ snap install snapcraft --candidate --classic
snap "snapcraft" is already installed, see 'snap help refresh'
artemis@artemis:~$ snap install multipass --beta --classic
multipass (beta) v0.5 from Canonical✓ installed
artemis@artemis:~$ cd mysnaps/
artemis@artemis:~/mysnaps$ cd autoskola3d/
artemis@artemis:~/mysnaps/autoskola3d$ ls
asla3d_files  snap
artemis@artemis:~/mysnaps/autoskola3d$ snapcraft
Launching a VM.
Launched: snapcraft-autoskola3d                                                 
2019-02-05T18:57:28Z INFO Waiting for restart...
core 16-2.37.1 from 'canonical' installed
snapcraft 3.1 from Canonical✓ installed
core18 18 from Canonical✓ installed
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-updates/main Sources [245 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [518 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [194 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [725 kB]
Fetched 1845 kB in 3s (737 kB/s)  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
25 packages can be upgraded. Run 'apt list --upgradable' to see them.
Installing build dependencies: binutils binutils-common binutils-x86-64-linux-gnu build-essential cpp cpp-7 dpkg-dev fakeroot g++ g++-7 gcc gcc-7 gcc-7-base git less libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libasan4 libatomic1 libbinutils libc-dev-bin libc6-dev libcc1-0 libcilkrts5 libcurl3-gnutls libdpkg-perl liberror-perl libfakeroot libfile-fcntllock-perl libgcc-7-dev libglib2.0-bin libglib2.0-dev libglib2.0-dev-bin libgomp1 libisl19 libitm1 liblsan0 libmpc3 libmpx2 libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libquadmath0 libstdc++-7-dev libtsan0 libubsan0 linux-libc-dev make manpages manpages-dev pkg-config python3-distutils python3-lib2to3 zlib1g-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  grub-pc-bin
Use 'sudo apt autoremove' to remove it.
Suggested packages:
  binutils-doc cpp-doc gcc-7-locales debian-keyring g++-multilib
  g++-7-multilib gcc-7-doc libstdc++6-7-dbg gcc-multilib autoconf automake
  libtool flex bison gdb gcc-doc gcc-7-multilib libgcc1-dbg libgomp1-dbg
  libitm1-dbg libatomic1-dbg libasan4-dbg liblsan0-dbg libtsan0-dbg
  libubsan0-dbg libcilkrts5-dbg libmpx2-dbg libquadmath0-dbg git-daemon-run
  | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-cvs
  git-mediawiki git-svn glibc-doc bzr libglib2.0-doc libstdc++-7-doc make-doc
  man-browser
The following NEW packages will be installed:
  binutils binutils-common binutils-x86-64-linux-gnu build-essential cpp cpp-7
  dpkg-dev fakeroot g++ g++-7 gcc gcc-7 gcc-7-base git less
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libasan4 libatomic1 libbinutils libc-dev-bin libc6-dev libcc1-0 libcilkrts5
  libcurl3-gnutls libdpkg-perl liberror-perl libfakeroot
  libfile-fcntllock-perl libgcc-7-dev libglib2.0-bin libglib2.0-dev
  libglib2.0-dev-bin libgomp1 libisl19 libitm1 liblsan0 libmpc3 libmpx2
  libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libquadmath0
  libstdc++-7-dev libtsan0 libubsan0 linux-libc-dev make manpages manpages-dev
  pkg-config python3-distutils python3-lib2to3 zlib1g-dev
0 upgraded, 56 newly installed, 0 to remove and 25 not upgraded.
Need to get 45.4 MB of archives.
Fetched 45.4 MB in 47s (965 kB/s)                                              
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package less.
(Reading database ... 14671 files and directories currently installed.)
Preparing to unpack .../00-less_487-0.1_amd64.deb ...
Unpacking less (487-0.1) ...
Selecting previously unselected package manpages.
Preparing to unpack .../01-manpages_4.15-1_all.deb ...
Unpacking manpages (4.15-1) ...
Selecting previously unselected package binutils-common:amd64.
Preparing to unpack .../02-binutils-common_2.30-21ubuntu1~18.04_amd64.deb ...
Unpacking binutils-common:amd64 (2.30-21ubuntu1~18.04) ...
Selecting previously unselected package libbinutils:amd64.
Preparing to unpack .../03-libbinutils_2.30-21ubuntu1~18.04_amd64.deb ...
Unpacking libbinutils:amd64 (2.30-21ubuntu1~18.04) ...
Selecting previously unselected package binutils-x86-64-linux-gnu.
Preparing to unpack .../04-binutils-x86-64-linux-gnu_2.30-21ubuntu1~18.04_amd64.deb ...
Unpacking binutils-x86-64-linux-gnu (2.30-21ubuntu1~18.04) ...
Selecting previously unselected package binutils.
Preparing to unpack .../05-binutils_2.30-21ubuntu1~18.04_amd64.deb ...
Unpacking binutils (2.30-21ubuntu1~18.04) ...
Selecting previously unselected package libc-dev-bin.
Preparing to unpack .../06-libc-dev-bin_2.27-3ubuntu1_amd64.deb ...
Unpacking libc-dev-bin (2.27-3ubuntu1) ...
Selecting previously unselected package linux-libc-dev:amd64.
Preparing to unpack .../07-linux-libc-dev_4.15.0-45.48_amd64.deb ...
Unpacking linux-libc-dev:amd64 (4.15.0-45.48) ...
Selecting previously unselected package libc6-dev:amd64.
Preparing to unpack .../08-libc6-dev_2.27-3ubuntu1_amd64.deb ...
Unpacking libc6-dev:amd64 (2.27-3ubuntu1) ...
Selecting previously unselected package gcc-7-base:amd64.
Preparing to unpack .../09-gcc-7-base_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking gcc-7-base:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package libisl19:amd64.
Preparing to unpack .../10-libisl19_0.19-1_amd64.deb ...
Unpacking libisl19:amd64 (0.19-1) ...
Selecting previously unselected package libmpc3:amd64.
Preparing to unpack .../11-libmpc3_1.1.0-1_amd64.deb ...
Unpacking libmpc3:amd64 (1.1.0-1) ...
Selecting previously unselected package cpp-7.
Preparing to unpack .../12-cpp-7_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking cpp-7 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package cpp.
Preparing to unpack .../13-cpp_4%3a7.3.0-3ubuntu2.1_amd64.deb ...
Unpacking cpp (4:7.3.0-3ubuntu2.1) ...
Selecting previously unselected package libcc1-0:amd64.
Preparing to unpack .../14-libcc1-0_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libcc1-0:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libgomp1:amd64.
Preparing to unpack .../15-libgomp1_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libgomp1:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libitm1:amd64.
Preparing to unpack .../16-libitm1_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libitm1:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libatomic1:amd64.
Preparing to unpack .../17-libatomic1_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libatomic1:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libasan4:amd64.
Preparing to unpack .../18-libasan4_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libasan4:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package liblsan0:amd64.
Preparing to unpack .../19-liblsan0_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking liblsan0:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libtsan0:amd64.
Preparing to unpack .../20-libtsan0_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libtsan0:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libubsan0:amd64.
Preparing to unpack .../21-libubsan0_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libubsan0:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package libcilkrts5:amd64.
Preparing to unpack .../22-libcilkrts5_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libcilkrts5:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package libmpx2:amd64.
Preparing to unpack .../23-libmpx2_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libmpx2:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libquadmath0:amd64.
Preparing to unpack .../24-libquadmath0_8.2.0-1ubuntu2~18.04_amd64.deb ...
Unpacking libquadmath0:amd64 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libgcc-7-dev:amd64.
Preparing to unpack .../25-libgcc-7-dev_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libgcc-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package gcc-7.
Preparing to unpack .../26-gcc-7_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking gcc-7 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package gcc.
Preparing to unpack .../27-gcc_4%3a7.3.0-3ubuntu2.1_amd64.deb ...
Unpacking gcc (4:7.3.0-3ubuntu2.1) ...
Selecting previously unselected package libstdc++-7-dev:amd64.
Preparing to unpack .../28-libstdc++-7-dev_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libstdc++-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package g++-7.
Preparing to unpack .../29-g++-7_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking g++-7 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package g++.
Preparing to unpack .../30-g++_4%3a7.3.0-3ubuntu2.1_amd64.deb ...
Unpacking g++ (4:7.3.0-3ubuntu2.1) ...
Selecting previously unselected package make.
Preparing to unpack .../31-make_4.1-9.1ubuntu1_amd64.deb ...
Unpacking make (4.1-9.1ubuntu1) ...
Selecting previously unselected package libdpkg-perl.
Preparing to unpack .../32-libdpkg-perl_1.19.0.5ubuntu2.1_all.deb ...
Unpacking libdpkg-perl (1.19.0.5ubuntu2.1) ...
Selecting previously unselected package dpkg-dev.
Preparing to unpack .../33-dpkg-dev_1.19.0.5ubuntu2.1_all.deb ...
Unpacking dpkg-dev (1.19.0.5ubuntu2.1) ...
Selecting previously unselected package build-essential.
Preparing to unpack .../34-build-essential_12.4ubuntu1_amd64.deb ...
Unpacking build-essential (12.4ubuntu1) ...
Selecting previously unselected package libfakeroot:amd64.
Preparing to unpack .../35-libfakeroot_1.22-2ubuntu1_amd64.deb ...
Unpacking libfakeroot:amd64 (1.22-2ubuntu1) ...
Selecting previously unselected package fakeroot.
Preparing to unpack .../36-fakeroot_1.22-2ubuntu1_amd64.deb ...
Unpacking fakeroot (1.22-2ubuntu1) ...
Selecting previously unselected package libcurl3-gnutls:amd64.
Preparing to unpack .../37-libcurl3-gnutls_7.58.0-2ubuntu3.5_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.58.0-2ubuntu3.5) ...
Selecting previously unselected package liberror-perl.
Preparing to unpack .../38-liberror-perl_0.17025-1_all.deb ...
Unpacking liberror-perl (0.17025-1) ...
Selecting previously unselected package git.
Preparing to unpack .../39-git_1%3a2.17.1-1ubuntu0.4_amd64.deb ...
Unpacking git (1:2.17.1-1ubuntu0.4) ...
Selecting previously unselected package libalgorithm-diff-perl.
Preparing to unpack .../40-libalgorithm-diff-perl_1.19.03-1_all.deb ...
Unpacking libalgorithm-diff-perl (1.19.03-1) ...
Selecting previously unselected package libalgorithm-diff-xs-perl.
Preparing to unpack .../41-libalgorithm-diff-xs-perl_0.04-5_amd64.deb ...
Unpacking libalgorithm-diff-xs-perl (0.04-5) ...
Selecting previously unselected package libalgorithm-merge-perl.
Preparing to unpack .../42-libalgorithm-merge-perl_0.08-3_all.deb ...
Unpacking libalgorithm-merge-perl (0.08-3) ...
Selecting previously unselected package libfile-fcntllock-perl.
Preparing to unpack .../43-libfile-fcntllock-perl_0.22-3build2_amd64.deb ...
Unpacking libfile-fcntllock-perl (0.22-3build2) ...
Selecting previously unselected package libglib2.0-bin.
Preparing to unpack .../44-libglib2.0-bin_2.56.3-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libglib2.0-bin (2.56.3-0ubuntu0.18.04.1) ...
Selecting previously unselected package python3-lib2to3.
Preparing to unpack .../45-python3-lib2to3_3.6.7-1~18.04_all.deb ...
Unpacking python3-lib2to3 (3.6.7-1~18.04) ...
Selecting previously unselected package python3-distutils.
Preparing to unpack .../46-python3-distutils_3.6.7-1~18.04_all.deb ...
Unpacking python3-distutils (3.6.7-1~18.04) ...
Selecting previously unselected package libglib2.0-dev-bin.
Preparing to unpack .../47-libglib2.0-dev-bin_2.56.3-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libglib2.0-dev-bin (2.56.3-0ubuntu0.18.04.1) ...
Selecting previously unselected package libpcre16-3:amd64.
Preparing to unpack .../48-libpcre16-3_2%3a8.39-9_amd64.deb ...
Unpacking libpcre16-3:amd64 (2:8.39-9) ...
Selecting previously unselected package libpcre32-3:amd64.
Preparing to unpack .../49-libpcre32-3_2%3a8.39-9_amd64.deb ...
Unpacking libpcre32-3:amd64 (2:8.39-9) ...
Selecting previously unselected package libpcrecpp0v5:amd64.
Preparing to unpack .../50-libpcrecpp0v5_2%3a8.39-9_amd64.deb ...
Unpacking libpcrecpp0v5:amd64 (2:8.39-9) ...
Selecting previously unselected package libpcre3-dev:amd64.
Preparing to unpack .../51-libpcre3-dev_2%3a8.39-9_amd64.deb ...
Unpacking libpcre3-dev:amd64 (2:8.39-9) ...
Selecting previously unselected package pkg-config.
Preparing to unpack .../52-pkg-config_0.29.1-0ubuntu2_amd64.deb ...
Unpacking pkg-config (0.29.1-0ubuntu2) ...
Selecting previously unselected package zlib1g-dev:amd64.
Preparing to unpack .../53-zlib1g-dev_1%3a1.2.11.dfsg-0ubuntu2_amd64.deb ...
Unpacking zlib1g-dev:amd64 (1:1.2.11.dfsg-0ubuntu2) ...
Selecting previously unselected package libglib2.0-dev:amd64.
Preparing to unpack .../54-libglib2.0-dev_2.56.3-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libglib2.0-dev:amd64 (2.56.3-0ubuntu0.18.04.1) ...
Selecting previously unselected package manpages-dev.
Preparing to unpack .../55-manpages-dev_4.15-1_all.deb ...
Unpacking manpages-dev (4.15-1) ...
Setting up libquadmath0:amd64 (8.2.0-1ubuntu2~18.04) ...
Setting up libgomp1:amd64 (8.2.0-1ubuntu2~18.04) ...
Setting up libatomic1:amd64 (8.2.0-1ubuntu2~18.04) ...
Setting up manpages (4.15-1) ...
Setting up libcc1-0:amd64 (8.2.0-1ubuntu2~18.04) ...
Setting up less (487-0.1) ...
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76.)
debconf: falling back to frontend: Readline
Setting up make (4.1-9.1ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Setting up liberror-perl (0.17025-1) ...
Setting up libcurl3-gnutls:amd64 (7.58.0-2ubuntu3.5) ...
Setting up libtsan0:amd64 (8.2.0-1ubuntu2~18.04) ...
Processing triggers for libglib2.0-0:amd64 (2.56.3-0ubuntu0.18.04.1) ...
No schema files found: doing nothing.
Setting up linux-libc-dev:amd64 (4.15.0-45.48) ...
Setting up libdpkg-perl (1.19.0.5ubuntu2.1) ...
Setting up liblsan0:amd64 (8.2.0-1ubuntu2~18.04) ...
Setting up gcc-7-base:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up binutils-common:amd64 (2.30-21ubuntu1~18.04) ...
Setting up libfile-fcntllock-perl (0.22-3build2) ...
Setting up libmpx2:amd64 (8.2.0-1ubuntu2~18.04) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libfakeroot:amd64 (1.22-2ubuntu1) ...
Setting up libalgorithm-diff-perl (1.19.03-1) ...
Setting up libpcrecpp0v5:amd64 (2:8.39-9) ...
Setting up libpcre32-3:amd64 (2:8.39-9) ...
Setting up libmpc3:amd64 (1.1.0-1) ...
Setting up libc-dev-bin (2.27-3ubuntu1) ...
Setting up libpcre16-3:amd64 (2:8.39-9) ...
Setting up python3-lib2to3 (3.6.7-1~18.04) ...
Setting up manpages-dev (4.15-1) ...
Setting up libglib2.0-bin (2.56.3-0ubuntu0.18.04.1) ...
Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
Setting up python3-distutils (3.6.7-1~18.04) ...
Setting up git (1:2.17.1-1ubuntu0.4) ...
Setting up libitm1:amd64 (8.2.0-1ubuntu2~18.04) ...
Setting up zlib1g-dev:amd64 (1:1.2.11.dfsg-0ubuntu2) ...
Setting up libisl19:amd64 (0.19-1) ...
Setting up libpcre3-dev:amd64 (2:8.39-9) ...
Setting up libasan4:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libglib2.0-dev-bin (2.56.3-0ubuntu0.18.04.1) ...
Setting up libbinutils:amd64 (2.30-21ubuntu1~18.04) ...
Setting up libcilkrts5:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libubsan0:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up fakeroot (1.22-2ubuntu1) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man1/fakeroot.1.gz because associated file /usr/share/man/man1/fakeroot-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/man1/faked.1.gz because associated file /usr/share/man/man1/faked-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/es/man1/fakeroot.1.gz because associated file /usr/share/man/es/man1/fakeroot-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/es/man1/faked.1.gz because associated file /usr/share/man/es/man1/faked-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/fr/man1/fakeroot.1.gz because associated file /usr/share/man/fr/man1/fakeroot-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/fr/man1/faked.1.gz because associated file /usr/share/man/fr/man1/faked-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/sv/man1/fakeroot.1.gz because associated file /usr/share/man/sv/man1/fakeroot-sysv.1.gz (of link group fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/sv/man1/faked.1.gz because associated file /usr/share/man/sv/man1/faked-sysv.1.gz (of link group fakeroot) doesn't exist
Setting up libgcc-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up cpp-7 (7.3.0-27ubuntu1~18.04) ...
Setting up libstdc++-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libalgorithm-merge-perl (0.08-3) ...
Setting up libalgorithm-diff-xs-perl (0.04-5) ...
Setting up binutils-x86-64-linux-gnu (2.30-21ubuntu1~18.04) ...
Setting up cpp (4:7.3.0-3ubuntu2.1) ...
Setting up binutils (2.30-21ubuntu1~18.04) ...
Setting up gcc-7 (7.3.0-27ubuntu1~18.04) ...
Setting up g++-7 (7.3.0-27ubuntu1~18.04) ...
Setting up gcc (4:7.3.0-3ubuntu2.1) ...
Setting up dpkg-dev (1.19.0.5ubuntu2.1) ...
Setting up g++ (4:7.3.0-3ubuntu2.1) ...
update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man1/c++.1.gz because associated file /usr/share/man/man1/g++.1.gz (of link group c++) doesn't exist
Setting up build-essential (12.4ubuntu1) ...
Setting up pkg-config (0.29.1-0ubuntu2) ...
Setting up libglib2.0-dev:amd64 (2.56.3-0ubuntu0.18.04.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
binutils set to automatically installed.
binutils-common set to automatically installed.
binutils-x86-64-linux-gnu set to automatically installed.
build-essential set to automatically installed.
cpp set to automatically installed.
cpp-7 set to automatically installed.
dpkg-dev set to automatically installed.
fakeroot set to automatically installed.
g++ set to automatically installed.
g++-7 set to automatically installed.
gcc set to automatically installed.
gcc-7 set to automatically installed.
gcc-7-base set to automatically installed.
git set to automatically installed.
less set to automatically installed.
libalgorithm-diff-perl set to automatically installed.
libalgorithm-diff-xs-perl set to automatically installed.
libalgorithm-merge-perl set to automatically installed.
libasan4 set to automatically installed.
libatomic1 set to automatically installed.
libbinutils set to automatically installed.
libc-dev-bin set to automatically installed.
libc6-dev set to automatically installed.
libcc1-0 set to automatically installed.
libcilkrts5 set to automatically installed.
libcurl3-gnutls set to automatically installed.
libdpkg-perl set to automatically installed.
liberror-perl set to automatically installed.
libfakeroot set to automatically installed.
libfile-fcntllock-perl set to automatically installed.
libgcc-7-dev set to automatically installed.
libglib2.0-bin set to automatically installed.
libglib2.0-dev set to automatically installed.
libglib2.0-dev-bin set to automatically installed.
libgomp1 set to automatically installed.
libisl19 set to automatically installed.
libitm1 set to automatically installed.
liblsan0 set to automatically installed.
libmpc3 set to automatically installed.
libmpx2 set to automatically installed.
libpcre16-3 set to automatically installed.
libpcre3-dev set to automatically installed.
libpcre32-3 set to automatically installed.
libpcrecpp0v5 set to automatically installed.
libquadmath0 set to automatically installed.
libstdc++-7-dev set to automatically installed.
libtsan0 set to automatically installed.
libubsan0 set to automatically installed.
linux-libc-dev set to automatically installed.
make set to automatically installed.
manpages set to automatically installed.
manpages-dev set to automatically installed.
pkg-config set to automatically installed.
python3-distutils set to automatically installed.
python3-lib2to3 set to automatically installed.
zlib1g-dev set to automatically installed.
Get:1 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]               
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]    
Get:3 http://security.ubuntu.com/ubuntu bionic-security/main Sources [74.3 kB] 
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]      
Get:5 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]    
Get:6 http://security.ubuntu.com/ubuntu bionic-security/universe Sources [30.2 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/main Sources [829 kB]            
Get:8 http://security.ubuntu.com/ubuntu bionic-security/multiverse Sources [2308 B]
Get:9 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [263 kB]
Get:10 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [98.6 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic/restricted Sources [5324 B]     
Get:12 http://archive.ubuntu.com/ubuntu bionic/universe Sources [9051 kB]      
Get:13 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [118 kB]
Get:14 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [67.0 kB]
Get:15 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [3332 B]
Get:16 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [1848 B]
Get:17 http://archive.ubuntu.com/ubuntu bionic/multiverse Sources [181 kB]     
Get:18 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1019 kB]   
Get:19 http://archive.ubuntu.com/ubuntu bionic/main Translation-en [516 kB]    
Get:20 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages [9184 B]
Get:21 http://archive.ubuntu.com/ubuntu bionic/restricted Translation-en [3584 B]
Get:22 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
Get:23 http://archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
Get:24 http://archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages [151 kB]
Get:25 http://archive.ubuntu.com/ubuntu bionic/multiverse Translation-en [108 kB]
Get:26 http://archive.ubuntu.com/ubuntu bionic-updates/main Sources [245 kB]   
Get:27 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Sources [2064 B]
Get:28 http://archive.ubuntu.com/ubuntu bionic-updates/universe Sources [126 kB]
Get:29 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse Sources [4196 B]
Get:30 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [518 kB]
Get:31 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [194 kB]
Get:32 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [6992 B]
Get:33 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en [3076 B]
Get:34 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [725 kB]
Get:35 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [183 kB]
Get:36 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [6388 B]
Get:37 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse Translation-en [3452 B]
Get:38 http://archive.ubuntu.com/ubuntu bionic-backports/universe Sources [2068 B]
Get:39 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [3472 B]
Get:40 http://archive.ubuntu.com/ubuntu bionic-backports/universe Translation-en [1604 B]
Fetched 28.6 MB in 6s (914 kB/s)                                               
Get:1 libelf1_0.170-0.4_amd64.deb [44.1 kB]                                    
Fetched 44.1 kB in 0s (0 B/s)                                                  
Get:1 libglib2.0-bin_2.56.3-0ubuntu0.18.04.1_amd64.deb [68.9 kB]               
Fetched 68.9 kB in 0s (0 B/s)                                                  
Get:1 libglib2.0-data_2.56.3-0ubuntu0.18.04.1_all.deb [4696 B]                 
Fetched 4696 B in 0s (0 B/s)                                                   
Get:1 libffi6_3.2.1-8_amd64.deb [17.9 kB]                                      
Fetched 17.9 kB in 0s (0 B/s)                                                  
Get:1 libglib2.0-0_2.56.3-0ubuntu0.18.04.1_amd64.deb [1168 kB]                 
Fetched 1168 kB in 0s (0 B/s)                                                  
Pulling desktop-glib-only 
Cloning into '/root/parts/desktop-glib-only/src'...
remote: Enumerating objects: 4, done.
remote: Counting objects: 100% (4/4), done.
remote: Compressing objects: 100% (4/4), done.
remote: Total 1305 (delta 0), reused 1 (delta 0), pack-reused 1301
Receiving objects: 100% (1305/1305), 230.68 KiB | 742.00 KiB/s, done.
Resolving deltas: 100% (679/679), done.
'game' has dependencies that need to be staged: desktop-glib-only
Skipping pull desktop-glib-only (already ran)
We strongly recommend enabling multi-factor authentication: https://help.ubuntu.com/community/SSO/FAQs/2FA

Login successful.
artemis@artemis:~/mysnaps/autoskola3d$ snapcraft push --release=stable autoskola3d_1.0_amd64.snap
Pushing autoskola3d_1.0_amd64.snap
After pushing, an attempt will be made to release to 'stable'
Preparing to push '/home/artemis/mysnaps/autoskola3d/autoskola3d_1.0_amd64.snap' to the store.
Pushing autoskola3d_1.0_amd64.snap [======================================] 100%
Processing...|                                                                  
Ready to release!
Revision 1 of 'autoskola3d' created.
Track    Arch    Channel    Version    Revision
latest   amd64   stable     1.0        1
                 candidate  ^          ^
                 beta       ^          ^
                 edge       ^          ^
The 'stable' channel is now open.
artemis@artemis:~/mysnaps/autoskola3d$