How can I launch snap-store?


#1

Hi evrybody, I’m a newbee. I installed snapd, snap-store and freemind but I can’t launch snap-store or freemind from my desktop or graphical.
I can launch freemind typing “snap run freemind” fron my console.
When I try to launch snap-store, this is the message I get:
"snap run snap-store
You need to connect this snap to the gnome platform snap.

You can do this with those commands:
snap install gnome-3-26-1604
snap connect snap-store:gnome-3-26-1604 gnome-3-26-1604

(the ‘3-26-1604’ number defines the platform version and might change)"
I type “snap install gnome-3-26-1604”
but when I type “snap connect snap-store:gnome-3-26-1604 gnome-3-26-1604”
this is the message I get:
"error: snap “snap-store” has no plug named “gnome-3-26-1604”
What can I do?
I’m on sparkylinux
Tanks


#2

The correct plug name is gnome-3-28-1804, as indicated in the snap connections snap-store command’s output:

$ snap connections snap-store
Interface                 Plug                                 Slot                             Notes
content[gnome-3-28-1804]  snap-store:gnome-3-28-1804           gnome-3-28-1804:gnome-3-28-1804  -
content[gtk-3-themes]     snap-store:gtk-3-themes              gtk-common-themes:gtk-3-themes   -
content[icon-themes]      snap-store:icon-themes               gtk-common-themes:icon-themes    -
content[sound-themes]     snap-store:sound-themes              gtk-common-themes:sound-themes   -
dbus                      -                                    snap-store:snap-store            -
desktop                   snap-store:desktop                   :desktop                         -
desktop-legacy            snap-store:desktop-legacy            :desktop-legacy                  -
gsettings                 snap-store:gsettings                 :gsettings                       -
network                   snap-store:network                   :network                         -
network-manager           snap-store:network-manager           -                                -
password-manager-service  snap-store:password-manager-service  :password-manager-service        -
snapd-control             snap-store:snapd-control             :snapd-control                   -
system-observe            snap-store:system-observe            :system-observe                  -
unity7                    snap-store:unity7                    :unity7                          -
upower-observe            snap-store:upower-observe            :upower-observe                  -
wayland                   snap-store:wayland                   :wayland                         -

#3

Thank’s a lot,
But it still not appears on the dashboard or the desktop and now I have a new problem when I type “snap run snap store”,
Here is the message I got:
$ snap run snap-store
19:10:13:0931 GLib-GIO g_app_info_get_name: assertion ‘G_IS_APP_INFO (appinfo)’ failed
19:10:14:0687 Gs enabled plugins: odrs, rewrite-resource, snap, icons, key-colors, key-colors-metadata
19:10:14:0687 Gs disabled plugins: appstream, desktop-categories, desktop-menu-path, dpkg, dummy, epiphany, fedora-pkgdb-collections, generic-updates, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, os-release, provenance, provenance-license, repos, shell-extensions
19:10:20:0264 Gs failed to create an app for ////system/*
19:10:20:0277 Gs updates-shell: failed to get updates: no plugin could handle get-updates
19:10:20:0278 Gs failed to create an app for ////system/*
19:10:20:0278 Gs failed to get system app
19:10:20:0278 Gs Only 0 apps for recent list, hiding
19:10:25:0256 Gs hiding category audio-video featured applications: found only 0 to show, need at least 9
19:10:25:0519 Gs hiding category productivity featured applications: found only 0 to show, need at least 9.
Could you help me,
Thank you