High CPU usage by gvfs-udisks2-vo caused by microk8s

Hi,

We get reports from users seeing high cpu usage. This does not seem to be related to snapcraft, but one of the users said that “there is the ‘x-gvfs-hide’ option you can provide when mounting”. I thought I’d ask here in case anyone knows more about that. You can read the investigation on the subject at [1].

Thanks

[1] https://github.com/ubuntu/microk8s/issues/500#issuecomment-508609860

Thanks for kicking this off @kjackal - full process name is gvfs-udisks2-volume-monitor. I was after seeing if I can add this mount option to the snap mounts to see if it has any effect. As @kjackal states, please take a look at the above github issue for further details.