Headphones stopped working after granting Audacity access to ALSA


I’m running Ubuntu 22.04.3 LTS/Windows 10 after a recent reinstall. Everything was clicking until I recently launched Audacity and a message popped up:

Audacity may have better audio device support if granted permission to access the ALSA audio system.

If you experience audio problems, you may wish to grant this access by using the Software Centre or the Snap Store to add the ‘alsa’ permission to Audacity. It is safe to continue without doing so.

You can also grant this permission by running the following command in a Terminal window:

sudo snap connect audacity:alsa

If you choose to continue and later wish to change your mind, you can remove the file /home/[user]/snap/audacity/common/Always use PulseAudio.

I ran the command and found that my headphones no longer worked. I’ve checked all the settings and the headphones work on Windows, so this clearly is due to running the command.

I’ve tried removing the file mentioned above to no effect. The following might be useful, though not to me:

xxxxxxxxxxxx:~$ snap connections audacity
Interface              Plug                      Slot                            Notes
alsa                   audacity:alsa             -                               -
audio-playback         audacity:audio-playback   :audio-playback                 -
audio-record           audacity:audio-record     -                               -
content[gtk-2-themes]  audacity:gtk-2-themes     gtk-common-themes:gtk-2-themes  -
content[icon-themes]   audacity:icon-themes      gtk-common-themes:icon-themes   -
content[sound-themes]  audacity:sound-themes     gtk-common-themes:sound-themes  -
desktop                audacity:desktop          :desktop                        -
desktop-legacy         audacity:desktop-legacy   :desktop-legacy                 -
gsettings              audacity:gsettings        :gsettings                      -
home                   audacity:home             :home                           -
jack1                  audacity:jack1            -                               -
network                audacity:network          :network                        -
network-bind           audacity:network-bind     :network-bind                   -
pulseaudio             audacity:pulseaudio       :pulseaudio                     -
removable-media        audacity:removable-media  -                               -
unity7                 audacity:unity7           :unity7                         -
wayland                audacity:wayland          :wayland                        -
x11                    audacity:x11              :x11

Help please.

OK, found where I can get help. Thanks anyway.

1 Like

Please tell what was the solution, i have tried endless things but nothing worked, connecting to bluetooth again and again is a headache

Sorry, I actually don’t remember how I fixed it. But I did fix it.

It may be that I reinstalled a more recent version of Audacity.