Having Issue while installing any package from snap on RHEL8

After installing snap (version 2.58-3) we were unable to install any packages and got the following error:

error: cannot perform the following tasks:

- Download snap “core” (16574) from channel “stable” (sha3-384 mismatch for “core”: got ba90c7eaf3771c33b6a3c24a7e7d79645895c639e5bbcad771cd4476e27813b07554eadfbf9e81fdd99833eabe563ae8 but expected 18a963205ce6d159c736df55649656a9640acb189db9c50e8e6ea08f7448d587435418deadaa14c30f5de205f5b246d9)

We also noticed the following the our messages log:

Feb 26 17:22:33 lrlutpci1 snapd[19445]: store_download.go:143: no host system xdelta3 available to use deltas

Where did you get snapd 2.58-3 from? I’ve uploaded 2.61.1 and 2.61.2 to EPEL archives earlier. Can you explain how did you use an older version?

Hi Zyga,

if you want to install specific version, then while installing snapd you can pass the version and thats how i did install, do you want me to install the 2.61.1 or you think the version can be an issue? you think the sha3 is from a different version and running version of snapd is different? would appreciate if you can provide any steps to resolve this issue?

I’m trying to figure out how you managed to get that specific version in particular. Can you help us by sharing how you’ve installed snapd? Typically the installation instructions generated on each snap store page are accurate:

Yeah! its the same process to install snapd on rhel 8, but while installing it just passed the desired version to install it.

Right, and did you pass a specific version? EPEL 8 currently has 2.61.1 (and will have 2.61.2 in a few days). Can you explain why did you pass the extra arguments to get an older version and if the bugs you’re seeing are gone in the current version? Thanks!

Yes initially we had 2.61.1 but we were having some issues while installing snap packages(microk8s) , so we try to downgrade the snapd version to see if its resolve the issue or not. you are recommending us to upgrade the snapd to latest available version and see if it resolves the issue or not ? or is there anything that you can help here would be appreciated. Thanks

Yes, let’s update to the latest version for now. As for the hash mismatches, if you give me instructions on how to reproduce that I can look as well. I have not seen that myself.

we upgraded the snapd version and we are kind of having same issue, here is the output.

sudo snap install hello-world error: cannot perform the following tasks:

  • Download snap “core” (16574) from channel “stable” (sha3-384 mismatch for “core”: got e62bd59bbf12fcd132164bb3709588e919db436aba468bfa63f47cc0c728ff20b478788348795dfb0e24f0ff4298da98 but expected 18a963205ce6d159c736df55649656a9640acb189db9c50e8e6ea08f7448d587435418deadaa14c30f5de205f5b246d9)

snap --version snap 2.61.1-0.el8 snapd 2.61.1-0.el8 series 16 rhel 8.9 kernel 4.18.0-372.80.1.el8_6.x86_64

I am attempting to reproduce this now. On a RHEL 8 VM with all the updates applied, I get:

[zyga@rhel-8 ~]$ snap version
snap    2.61.2-0.el8
snapd   2.61.2-0.el8
series  16
rhel    8.9
kernel  4.18.0-513.11.1.el8_9.x86_64
[zyga@rhel-8 ~]$ sudo snap install hello-world
[sudo] hasło użytkownika zyga: 
hello-world 6.4 from Canonical✓ installed

Can you run snap download hello-world to see if the binary is somehow corrupted?

[zyga@rhel-8 ~]$ snap download hello-world
Fetching snap "hello-world"
Fetching assertions for "hello-world"
Install the snap with:
   snap ack hello-world_29.assert
   snap install hello-world_29.snap
[zyga@rhel-8 ~]$ sha256sum hello-world_29.snap 
a14a4c44b085499d45f4182388b941fc9d5d87c5fe04f7405e087f52da61c407  hello-world_29.snap

Similarly for core:

[zyga@rhel-8 ~]$ snap download core
Fetching snap "core"
Fetching assertions for "core"
Install the snap with:
   snap ack core_16574.assert
   snap install core_16574.snap
[zyga@rhel-8 ~]$ sha256sum core_16574.snap 
2c9de04cf23ff447f17575f9055f3919a76ff6d5b453354cdb3b2113b0e34a59  core_16574.snap

Are you behind some network proxy by any chance?

HI Zyga,

We are not behind any network proxy, we are able to reach api.snapcraft.io, we tried to install hello-world but all snap packages are behaving same and throwing same error. we tried to install nano, hello-world, microk8s all packages are giving same error so it seems snapd is not installed properly but we didnt face any issue during installation so yeah we are blind here.

Can you try to snap download any of the snaps I’ve listed and provide the hashes?

Hi Zyga,

Yes as soon as i got system access i will execute and share the output here. Thanks

Hi Zyga,

The problem here is i am unable to download any snap package as well, its saying the same thing on download as well. This is very weird.

This is quite unexpected. Let me conjure up some commands to download a snap without snap command in the loop, perhaps we can find out what’s wrong this way.

That would be great! one more thing like if you have a list of urls those needs to be whitelisted on firewall to download any package from snap so i can get those verified from network security team as well. Thanks


1 Like