Gsettings interface not working properly in Ubuntu 17.10 (Gnome Shell)

Hi all!

I have a snap published in the Ubuntu Store some time ago. It is called wallpaperdownloader (

Using this application users can download wallpapers from the Internet and change the current wallpaper among other things.It has been working flawlessly in Unity and MATE, but now I’m testing the snap in Ubuntu 17.10 (xorg session) and I have found some errors. Unity and GNOME command executed within the application is the same for changing the wallpaper: gsettings set org.gnome.desktop.background picture-uri file://blablabla.jpg but now an error is thrown:

[08:13:23] AWT-EventQueue-0 ERROR LinuxWallpaperChanger:163 -
[08:13:23] AWT-EventQueue-0 ERROR LinuxWallpaperChanger:163 - (process:12914): dconf-WARNING **: failed to commit changes to dconf: Error sending credentials: Error sending message: Operation not permitted

These are the interfaces used and defined via snapcraft.yaml file:

    plugs: [x11, unity7, network-bind, home, gsettings]

I have the impression that gsettings interface is still not working properly for Gnome session. Could it be this the problem?

Thank you very much!


Sorry, I forgot to mention I’m using desktop-gtk3 helper. This is the snapcraft.yaml file:

name: wallpaperdownloader
version: "2.8"
summary: Download, manage and change your favorite wallpapers from the Internet
description: WallpaperDownloader is a simple GUI Java based application for downloading, managing and changing wallpapers from the Internet
grade: stable
confinement: strict

    plugs: [x11, unity7, network-bind, home, gsettings]

  # Pulls the code from the original source (master branch)
  # desktop-gtk3 is a snapcraft part (snapcraft-desktop-helpers) from the Wiki:
  # It enables desktop integration and gsettings manipulation from the confined application
  # It is necessary to use gsettings interface (see above) in order to have a fully functional
  # desktop-gtk3 part
  # Github repository for snapcraft-desktop-helpers:
    plugin: maven
    source: ..
      # mate-desktop-common is necessary to have MATE gsettings schemas available for the application
      - mate-desktop-common
    after: [desktop-gtk3]

  # It will copy wallpaperdownloader script into /bin/
  # This script contains all the commands needed (sets env variables, launches the jar file...) to
  # execute the application
    plugin: dump
    source: scripts


Today, I have installed again 17.10 and now it seems it’s working properly. I did an upgrade of the system and rebooted, then it worked again.

I suppose it is because of the alpha state of 17.10. Nevertheless, I have experimented problems with the application icon. It is not displayed on Gnome Shell Dashboard, although, again, it could be because of the alpha version.

Thank you again :slight_smile:

Best whishes,