Gitkraken + raspberry pi = Exec format error

Is this the right place to report a bug in a snap package?

I tried installing the gitkraken snap on a Raspberry Pi 4B (following instructions at

After rebooting and installing the core, I got gitkraken installed as follows:

pi@raspberrypi:~ $ sudo snap install gitkraken --classic
Warning: flag --classic ignored for strictly confined snap gitkraken

gitkraken 4.0.2 from gitkraken✓ installed
pi@raspberrypi:~ $

But when I tried it out, it didn’t work: pi@raspberrypi:~ $ gitkraken /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_AU.UTF-8) /snap/gitkraken/93/bin/desktop-launch: line 477: /snap/gitkraken/93/usr/share/gitkraken/gitkraken: cannot execute binary file: Exec format error /snap/gitkraken/93/bin/desktop-launch: line 477: /snap/gitkraken/93/usr/share/gitkraken/gitkraken: Success pi@raspberrypi:~ $ file /snap/gitkraken/93/usr/share/gitkraken/gitkraken /snap/gitkraken/93/usr/share/gitkraken/gitkraken: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, for GNU/Linux 2.6.32, stripped pi@raspberrypi:~ $

It looks like the snap includes the x86-64 version of gitkraken instead of ARM aarch64.

Also, gitkraken 4.0.2 is very old now. The current version of gitkraken is 8.10.3.

GitKraken is my favourite git front end. I’d rather have it working on my pi if possible.

In general, no. It will only work when the snap developer is active on the forum. In this case…

$ snap info gitkraken | grep contact

So, the right place is probably:

1 Like

Thank you for your advice. Reported upstream.

1 Like