Gimp broken - again - missing shared library

Today Gimp is broken again and doesn’t start. The error I get:
/snap/gimp/273/usr/bin/gimp: error while loading shared libraries: cannot open shared object file: No such file or directory

The same issue happened before already (Gimp broken) but this time clearing the name space (sudo /usr/lib/snapd/snap-discard-ns) and also deleting ~/snap/gimp did not help. I still get the same error.

I was able to remove and reinstall gimp but the error remains.

snap changes shows some errors from the last days.

842  Error   yesterday at 17:25 CEST  yesterday at 17:25 CEST  Auto-refresh snap "gnome-3-28-1804"
843  Error   yesterday at 20:50 CEST  yesterday at 20:50 CEST  Auto-refresh snap "gnome-3-28-1804"
844  Error   today at 03:10 CEST      today at 03:10 CEST      Auto-refresh snap "gnome-3-28-1804"
845  Error   today at 06:45 CEST      today at 06:45 CEST      Auto-refresh snap "gnome-3-28-1804"
846  Done    today at 09:41 CEST      today at 09:42 CEST      Remove "gimp" snap
847  Done    today at 09:42 CEST      today at 09:42 CEST      Install "gimp" snap

Some details about my system.

snap version:
snap    2.45
snapd   2.45
series  16
ubuntu  20.04
kernel  5.4.0-24-generic

snap connections gimp:

Interface                 Plug                  Slot                              Notes
content[gnome-3-28-1804]  gimp:gnome-3-28-1804  gnome-3-28-1804:gnome-3-28-1804   -
content[gtk-2-engines]    gimp:gtk-2-engines    gtk2-common-themes:gtk-2-engines  -
content[gtk-3-themes]     gimp:gtk-3-themes     gtk-common-themes:gtk-3-themes    -
content[icon-themes]      gimp:icon-themes      gtk-common-themes:icon-themes     -
content[sound-themes]     gimp:sound-themes     gtk-common-themes:sound-themes    -
cups-control              gimp:cups-control     -                                 -
dbus                      -                     gimp:dbus-gimp                    -
desktop                   gimp:desktop          :desktop                          -
desktop-legacy            gimp:desktop-legacy   :desktop-legacy                   -
gsettings                 gimp:gsettings        :gsettings                        -
home                      gimp:home             :home                             -
network                   gimp:network          :network                          -
opengl                    gimp:opengl           :opengl                           -
removable-media           gimp:removable-media  -                                 -
unity7                    gimp:unity7           :unity7                           -
wayland                   gimp:wayland          :wayland                          -
x11                       gimp:x11              :x11                              -

I re-installed Gimp a few times, tried the snap-discard-ns a few times but without success.

Over the last days Nautilus showed around five 73MB sized partitions that looked very Snap specific. Anoying but it didn’t hurt. But as Gimp didn’t want to start and these partitions seemd somehow related I decided to reboot my computer.
All right, the partitions are not shown any more and Gimp works again.

Would be great if these issues get fixed.