Foobar2000 can't read inside my internal HDD and external HDD

So my problem is that I installed the foobar2000 snap, used “snap connect foobar2000:removable-media” as told on github, but if I try to seek, in foobar, for the folders which has my music, it appears as empty (the root of my external HDD). It also can’t seem to read anything inside my internal HDD.
Manjaro XFCE installed on an internal SSD.
This is what appears when I try to open a flac file directly with foobar2000 from my external HDD, for example:
“Unknown commandline parameter: /home/kefka/backup/Zona Musica/Zona Musica Albums/[1992.12.07] FINAL FANTASY V ORIGINAL SOUND VERSION【N33D-013~4】/[1992.12.07] FINAL FANTASY V ORIGINAL SOUND VERSION/Disc 1/01 - Nobuo Uematsu - Main Theme of Final Fantasy V.flac”
The drives are both mounted at “~/X” as you can see this one is called backup because it’s the external HDD.

Not quite clear to me why it does not let you access the drives mounted in your home directory. The foobar2000 snap also uses the home plug, which gives access to your entire home directory, so IMHO this should work for your case. The error message rather indicates a different kind of error. How do you add this file? Via GUI file selector or drag and drop?

The “removable-media” plug gives access to drives mounted under /mnt/, /run/media/ and /media/.

See also

I right clicked it from my external hdd and did run with foobar… I edited some stuff in fstab, and reinstalled foobar with snap, I’ll let you know in a few minutes if anything changed.
I will also use the home plug.
P.S. the home plug is on by default apparently

Ok I think the fstab edits fixed it, I can now access the content from foobar without much problem it seems…I want to wait just a bit more and see if it finishes processing the songs correctly and let me play them

Sooooo I had to manually type the directory in foobar’s media library browser but it worked…except it shows the media library as “E:\Zona Musica” (music zone lol) instead of “Z:\home\kefka\backup\Zona Musica” with “backup” being my actual external HDD mount point…idk what I did wrong on that side, but it’s letting me play music at least.