Foobar2000 cannot access cd drive

I have installed foobar2000 on Ubuntu 20.04 with “removable-media”, but any time I try to access the CD drive, I gen an error: “No CD Drives Found”.

foobar probably needs to add the optical-drive plug as well to its plugs definition …

I’m a newbie to this whole snap thing…

Is that something a user can do, or does the snap creator have to implement this?

this is something the snap creator/maintainer has to do …
looks like this is @mmtrt

(note that there might be more to it than just adding the plug to make the cd drive actually available inside wine in the snap)

I’ve added optical-drive to snap now it should have access to it, though I can’t test this locally no optical drive on my machines.

What’s the best way to implement this, uninstall/install with optical-drive?

just refresh the snap and connect the optical-drive plug …

Just updated foobar, but it still doesn’t access the CD-drive. Does it work for anybody else now??

did you connect the snap plug ?

No i didn’t. i’m quite new to Linux, i’m just reading/researching how to do this… thanks for the hint, i’ll see if it works then.

When i check the connections for foobar via the Terminal “optical-drive” is connected, but foobar still doesn’t find the CD-drive. Maybe i’m missing out something else?