Flutter plugin doesn't support Dart3.0

This plugin doesn’t appear to be using the newest stable releases of Flutter and Dart.

Specifically, “flutter pub get” is failing when version 3.0 of the Dart SDK is required:

SLVR: fact: treetag requires SDK version >=3.0.0 <4.0.0

The current Dart SDK version is 2.19.6.

Because treetag requires SDK version >=3.0.0 <4.0.0, version solving failed.

Does this plugin need to be updated? Or am I missing something else?

Use flutter from git.

Check this to use flutter built from source