Firefox snap seems to not taking account of system preferences


I’m using Firefox snap on a fresh Ubuntu 22.04 install. In my company, all developers have the same configuration, so until now, they have to manually import our certification authority from the Firefox preferences. I tried to add a global override config file in /etc/firefox/prefs, but it seems to not be read. On fresh install, there is a /etc/firefox/pref/apturl.js which should call gnome software when I click on a apt:// link. I say should because, in the preference window, I see the apt:// link are called by system-handler instead of directly call gnome-software. I tried to delete the mentionned file, and my Firefox preferences are not altered. I wonder if either the preferences are created during the profile creation (in this case, the described behaviour is expected), or if the config files in /etc/firefox/prefs are not loaded during firefox startup.

Thanks for your help. Regards.

In Ubuntu 22.04 the packaging of Firefox has changed, it is now packaged as a strictly-confined snap. This means that it generally cannot read files on the host system any longer, except for custom policies under /etc/firefox/policies/. Custom preferences under /etc/firefox/pref/ will be ignored.

You can now set default preferences using custom policies, see the relevant documentation.