Firefox pinch to zoom not working on 22.04

I installed 22.04 on a Macbook pro capable of multitouch gestures. I was previously running 21.10 and was able to use pinch to zoom on the Firefox snap, on 22.04 however I’m unable to use this gesture. I decided to test whether this affected other browsers, Chrome using the ozone wayland backend (from google’s deb package) allows pinch to zoom, epiphany v42 (flatpak) allows pinch to zoom. Firefox from Mozilla’s tarball allows pinch to zoom (v98.0.2).

1 Like

Can you attach the output of sudo dmesg |grep DENIED ?

That’s possibly related to bug #1964541, where drag and drop doesn’t work for the firefox snap under jammy in a wayland session.

I ran sudo dmesg | grep DENIED but the only apparmour denials I got were for discord installed as a snap, so unrelated. I ran Firefox from the terminal to see if it would throw any errors and provide any clues when attempting to use the gesture but ended up getting no warnings or errors.

I can keep an eye on when a fix gets issued for that bug and give pinching another go, if there’s anything else I can provide to help debug this, I’d be happy to help.

Thanks for the offer! I’m not seeing any denials either, yet the problem clearly has to do with confinement. One thing you could try is to run directly /snap/firefox/current/usr/lib/firefox/firefox and see if pinch-to-zoom works there. Please note that this is only for testing purposes, running a snap binary like this is unsupported and likely to break in many funny ways, if it launches at all (although it appears to work for firefox under jammy, by chance).

I’m actively investigating the issue I linked to, so I suggest you subscribe to the bug report to get notified when a fix is available.

No problem. Running the binary directly with MOZ_ENABLE_WAYLAND=1 exported does allow me to use pinch to zoom.

Subscribed to the report. Fingers crossed whenever the fix is issued results in a fix for this problem as well, thanks for looking into this.

Followed the progress on the drag and drop bug in launchpad. The patch to mutter does get drag and drop working on Wayland but unfortunately pinch gestures still don’t work.

Which version of the firefox snap is running? 99.0.1 was reverted to use xwayland until wayland support is propertly tested in an automated manner, so maybe this helps?

Yep I noticed that stable is now using xwayland so I switched to the beta channel, my previous comment was regarding version 100.0b5-1

The revert to xwayland also make touchpad scrolling way less smooth. The plan is for firefox to not support wayland on 22.04 stable?

Raised a bug in launchpad:

Pinch to zoom seems to be working for me now. I’m using the beta channel (version 102.0b2-1 revision 1415) and snapd 2.55.5. Anyone else able to confirm it working for them?