Firefox-geckodriver package is now missing from Ubuntu 22.04

There is no deb package for Firefox any more (, no firefox-geckodriver package either (

Now they use some kind of Firefox snap package.

How to install firefox-geckodriver with snap?

Where is a site like to browse/search for the snap packages and files? I need to know what files are in the firefox package. Maybe geckodriver binary is there for example, maybe geckodriver file is in some other package, sometimes I need to find some specific scripts or header files inside the packages, I need to see what I install.

Have you tried find /snap/firefox/current/ -ls ? It’s just a mount, all files shipped by the firefox snap are under that mount point.

I don’t think that store maintains a register of all files from snaps, that would be infeasible as the same file can be a part of many snaps, however that doesn’t matter, as those files are only consumed by the snap application when it runs. For instance, it would be weird if a confined snap shipped the header files.

AFAIK snap store maintains a register of commands (i.e. apps) from all snaps, which is already integrated with apt advise and command-not-found.

I don’t have the snap installed. What’s infeasible is for me to install all snap packages to search for a file in the mounts.

The same file can be a part of a deb package, and there is a search by file name on . I don’t see the infeasibility for snaps to do the same.

What do you mean by “apt advise” and “command-not-found”? I can’t google anything with those generic terms. It’s some automatic search that is supposed to suggest a package when executing an unknown command on the command line? In an Ubuntu 22.04 container I’ve tried to execute some commands that should be in the snap packages (like firefox or vlc), it gives just “bash: vlc: command not found”. It should point to a snap that exists? Should I install some “apt advise” and “command-not-found” software into the container and keep the container around to search for the commands?

Snapd does not run in a container, unless you tried lxd. Still in a fresh container it will not show provide any hints to apt, as we’ve had requests to not poke fetch the commands data too early.

It’s probably best if you file a bug at snapd cannot really provide a replacement for an infrastructure service, so IMO this falls to snap store.