Firefox from Ubuntu snap store doesn't support Download Helper

.deb file external application is not successfully integrated with Download Helper on Firefox Snap

1 Like

Please elaborate: what are you trying to do, and how is it not working exactly? A concrete example would be helpful, for people to understand the issue and address it.

Do you mean that you’re trying to Open a file directly with a program rather than Saving it? This is a known issue, last comment from a dev was in August 2017. I don’t think that we can do anything about this issue other than wait for devs to get round to thinking about it some more, do Like the posts there though! :slight_smile:

Also, actually, I wonder if some more recent work going on would fix this issue.

oSoMoN and Ads20000, thank you very much for answer.
Issue you understand very good, if you have installed Firefox from Ubuntu Software (Snap version) and when you trying download video with add-on Download Helper. It doesn’t work.
Download Helper work with external .deb application. API of addon with external application of Download Helper is not connected

Ah, I misunderstood then, you’re talking about an extension called ‘Download Helper’ :slight_smile:

Yes :slight_smile: https://addons.mozilla.org/sk/firefox/addon/video-downloadhelper/

1 Like

I would like to know whether this issue has been resolved as yet. It seems the snap version doesn’t support extensions. I had to uninstall the snap version and install the .deb version form Ubuntuzilla ppa in order to make the extension work. Kindly update so that we can use the official snap version of Firefox with ease.

2 Likes

Extensions in general are supported. Some types of extensions don’t work well though. This specific case looks quite similar to bug 1462888.

1 Like

I tried to install this Video DownloadHelper Companion App 1.2.4 from here https://www.downloadhelper.net/install-coapp?browser=firefox, but It has not recognized by firefox snap

Someone found the way to make this extension works on Firefox snap? It could be helpful with Ubuntu 22.04, now Firefox’s gonna be per default snap version.

It seems the snap package does not have permissions to access the native app. It should be very simple for users to set the permissions so it will work.

I am going to open a new ticket, but I guess the fact that I can no longer drag and drop an image from a website into Gimp has the same problem. (A dragged image is saved in /tmp/dnd_file and then opened in Gimp, but the file is not written.)

Native messaging support is being added to the firefox snap. Can you test that extension with the snap in the beta channel? See Call for testing: native messaging support in the Firefox snap for instructions, and please share your observations there. Thanks!

Just tried the beta snap today, didn’t help for me. BUT! I decided to look into it and found a workaround! (After I had some HLS files I really wanted to grab, I had been copying things into jdownloader as a temporary fix). This method works on stable firefox 105, it does not rely on the beta. (My user is hwertz, put your username in place.

Went to /home/hwertz/snap/firefox/common/ cp -av /opt/net.downloadhelper.coapp . ^-- you could probably make a symlink instead, but I didn’t test this. The coapp does not update that often anyway.

Went to /home/hwertz/snap/firefox/common/.mozilla cp -av /usr/lib/mozilla/native-messaging-hosts . cd native-messaging-hosts edit the net.downloadhelper.coapp.json, change “path” so where it starts with “/opt/” it instead starts with “/home/hwertz/snap/firefox/common/” (i.e. so it looks for the coapp in the net.downloadhelper.coapp directory you just copied instead of the one in bin.) I don’t know if you can use “~/snap/firefox/common/” here (using ~ for your home directory, which’d be nice since you then would have a .json file that can not be tied to a specific user.)

Interesting. Thanks for sharing your feedback @hwertz. This likely works because net.downloadhelper.coapp doesn’t have any external dependencies, because you copied it to a place that’s accessible inside the snap’s sandbox (symlinking wouldn’t work), and because you used fully-qualified paths in the modified manifest (using the ~ shortcut wouldn’t work).

That’s a lot of constraints, and most native applications wouldn’t work like this in a confined firefox because of external dependencies (be they shared libraries, python modules, …). So that’s a rather limited solution, and one we cannot recommend for the general use case, but good to know that it works in this specific case anyway.

I have tried your solution with Ubuntu 22.04

  1. copy the directory downloadhelper.app to ~/snap/firefox/common
  2. copy the directory native-messaging-hosts to ~/snap/firefox/common/.mozilla
  3. edit the file net.downloadhelper.coapp.json with opt replaced by /home/michel/snap/firefox/common But it doesn’t work. When I try the preferences of the extension VDH, I have always an error when I test the application companion.

Yeah, you’re not doing it wrong, after some snap update this solution quit working. (I have downloadhelper saying the helper is not installed.)

So far, my solution has been to use jdownloader, which doesn’t work for everything but works for enough. There is a jdownloader add-on that adds some in-browser goodies to help get links into jdownloader (and also allows jdownloader control to open up a captcha window for those web sites that require a captcha to download from.) If you haven’t used it, it uses alarming amounts of CPU time at startup (I think due to Java’s “Just in Time” compiling going nuts on all that code), but once that’s done it runs nicely even on older systems.