Firefox 83.0 snap was* broken (fixed square fonts)

Hello everyone

Original problem:
I think the Firefox snap is broken, something happens with an update (I guess), now the snap does not work, already try the latest/stable channel with 83.0-2 and the channel esr/stable 78.5.0esr-1 both crashes with the following error:


Yesterday the FireFox snap was working great, now just crash, does anyone else have this problem with the latest/stable channel or the esr/stable?

Edit (FIX):
I manege to fixed following this

I just uninstall the snap then I update local font cache and that fixed for me.

I would leave this here, maybe someone face the same problem.

how fonts get corrupted like that even without the user doing anything?

Glad you found a workaround for the problem Eduardo.

You are right, this issue is concerning and should definitely not happen when the snap is being updated without user intervention. I wonder whether this was caused by the snap being refreshed while it was running? If so, that would be yet another symptom of bug #1616650, which can be mitigated by turning on the Refresh App Awareness experimental feature.

In any case, let’s keep this thread open, in case others stumble upon the same problem.

Ooooooh YES it’s a somewhat usual snap issue, that happens periodically!
Last one for me:

So sometimes it’s easy to see this issue to be fonts-related, sometimes not…

Yes indeed, actually the first time that happened to me was with the snap store (Ubuntu store) its self, in that moment what I did was to re-install Ubuntu from scratch, but now that I’m using Ubuntu as my personal daily drive that’s not an option, I think its a problem really difficult to fix if you are a “regular” no technical savvy users, because the usual IT procedure of uninstall and reinstall the snap (firefox in this case) does not fix the problem, you rely in using at least 2 commands from the terminal that are a little cryptic so its not ideal, this plus you don’t really have a notification o something that indicate than a snap its updated make it more difficult to track was happen.

this are just my thoughts as a really new user to Ubuntu and Linux by proxy.

Indeed, the fact that an application can be updated under your feet while running is counter-intuitive and not user-friendly, and the consequences can be nasty.
My understanding is that the plan is for [WIP] Refresh App Awareness to be turned on by default in the near future, thus largely mitigating the problem. I don’t know the exact date though.

That is great, because now my “normal” procedure when using my Ubuntu laptop is check all the updates before start using the machine for work, once I check all the updates, l feel safe to start using all the snaps that I love!

this happens to me after I get notified to restart because it was updated in the background.
I click the button to restart, and this happens (this is from KDE Neon 20.04)

It also happens sometimes when I get notified to restart to apply the update (screenshot from Ubuntu 21.04 on Unity desktop)

Restarting the application seems to fix it for me.

Yes @YamiYukiSenpai it’s an annoying problem that pops up from time to time
did you managed to fix it?

Nope. I still restart the app 2x (once with the “Restart Firefox” button, and other with closing and reopen).
I haven’t tried what happens if I close it and reopen instead of clicking the button yet.

as mentioned above already, [WIP] Refresh App Awareness will work around this, you can already enable it as an experimental feature today (it still has some rough edges)

I’ve been running my system with the following settings for months now. It isn’t optimal because it means I don’t immediately get updates in the background, but I like it this way.

Turn on refresh-app-awareness

This seeks to prevent applications from updating when they’re running.

snap set core experimental.refresh-app-awareness=true

Install Snap Manager GNOME Extension

Obviously only useful if you run GNOME Shell (which I do). This pops up when there are updates, with a button to refresh the applications, or ignore it and do them later.

Defer updates perpetually

Add a cron job to root which runs every day to push back the next update for long periods. snapd will intervene at some point (60 days) and force refresh, but I will typically have manually updated by then anyway.

30 17 * * * /usr/bin/snap set system refresh.hold="$(/usr/bin/date --iso-8601=seconds -d '+30 days')"

The result is updates are held, but I can do them when I want.

alan@mcp:~$ snap refresh --time
timer: sun,12:00
last: 23 days ago, at 12:09 GMT
hold: in 29 days, at 17:30 GMT
next: 9 days ago, at 12:00 GMT (but held)
1 Like

Any plans on supporting other desktop environments?

From my side, no at all. It’s already time-consuming to make a GS extension for non-gjs-skilled guys like me.

It would be wonderful that snapd at least optionally emits some notification or signal (is libnotify desktops-UI-wide ?) when a snap is auto-updated. Because my extension does not notify about updates that happen. It checks if there are updates at desktop startup and also show a button to see the recent changes. I absolutely do not know how to make a real-time notification function about snap updating process.

1 Like

@frederik-f (who suggested to clean up the notification)

v27 adds an option to hold updates for 1 month (no I won’t add a 2 months one…) and cleans up the snap-to-be-updated notification
v28 displays the auto-update state in startup notification (and adds hold delay if needed, to remind us when will be threatened)

edit: v29 will shorten the message in notification (useful if you have a lot of pending updates), v30 shortens time formatting, show next auto-update, increases the delay for the notification at startup.


Thanks @fthx Your extensiosn becomes more and more mandatory, since the local snap store app built with gnome software does not even start anymore :frowning:

I must confess that I switched to Debian 11 – with Yaru icons!! :wink: . Well, the Debian upgrade setup is (like Fedora’s) native and good: Software warns about all upgrades (deb or snap).

I use my extension for snap stuff, of course, but mainly for holding upgrades. So, again!, Software warns me about available snap upgrades but I simply have to validate the upgrade.

Please note that you have a Snap options > Revert snap refresh… menu item. :wink:

did you report a bug about that ? normally there is a rather large outcry if it fails for a bigger amount of people … it works here on all machines and i have not seen any recent report after the last fix …

Don’t know if it’s related, but I had these days to delete ~/.cache/fontconfig folder to recover some of my snaps (VLC, Gimp, Xournalpp, …).

(Still not easy to find for a normal user. The fact that’s a longstanding issue saved me through my memory…)

Oh didn’t see this at first, sorry.

I was using the snap-store snap from the edge channel and it was not starting for some weeks. I switched back to stable and now it opens up again. Was really not opening up at all, so whatever is in the edge channel :slight_smile: Can’t say much about that :slight_smile:

1 Like