Failed at startup


I try to start “gitkraken” first time and got the following error:

/snap/gitkraken/111/bin/desktop-launch: line 511: /snap/gitkraken/111/usr/share/gitkraken/gitkraken: cannot execute binary file: Exec format error
/snap/gitkraken/111/bin/desktop-launch: line 511: /snap/gitkraken/111/usr/share/gitkraken/gitkraken: Success

can anyone help?


This seems odd, as if the binary is for a different architecture than your host. Can you post the output of these 2 commands?

  • file /snap/gitkraken/current/usr/share/gitkraken/gitkraken
  • uname -a
1 Like


I am trying to install Gitkraken on my Jetson nano and came across the same error, as you say it seems snap is fetching the wrong binaries. I got past this one with: “sudo apt install binfmt-support qemu qemu-user-static” - but it still wont launch as it says it is unable to find the library: lib64/ - tried various things but still not able to get past it (strace below). Looked to see if I could download arm64 compiled binaries from the Gitkraken website but couldnt find anything matching. Qemu doesn’t seem the way to go either as I know it will be incredibly slow as Gitkraken can be quite intensive, really want to get it to work for Nano as I now have a development machine 90% there!

faccessat(AT_FDCWD, "/etc/qemu-binfmt/x86_64/lib64/", F_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/lib64/", O_RDONLY) = -1 ENOENT (No such file or directory)
write(2, "/lib64/ No "..., 55/lib64/ No such file or directory
) = 55
exit_group(-1)                          = ?
+++ exited with 255 +++

Any help would be greatly appreciated.

Best Regards, Jay

Looks like Gitkraken for arm has not been updated since 2019, perhaps you should get in touch with the publisher and inquire about the status?