Fail to install snapd

I want to update my telegram desktop to the latest version which needs snapd as I concerned. When I wanted to install it, it comes with this message:

You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
libsane1 : Breaks: libsane1:i386 (!= 1.0.27-1~experimental3ubuntu2.2) but 1.0.27-1~experimental3ubuntu2.1 is to be installed
libsane1:i386 : Depends: libsane-common:i386 (= 1.0.27-1~experimental3ubuntu2.1)
Breaks: libsane1 (!= 1.0.27-1~experimental3ubuntu2.1) but 1.0.27-1~experimental3ubuntu2.2 is to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

I’m new to linux, anyone can help? thanks

Which version of Ubuntu are you using? Snapd should already be installed on all supported versions of Ubuntu afaik.

I’m using Mint 19. So why when I type this command:

sudo snap install telegram-desktop

it says: snap: command not found

I found that the comman:
sudo apt-get install -f
fixed the issue