Error with installing snaps on raspberry pi

i have been trying to find a repository that is kept up to date for raspberry pi and flathub/flatpak doesn’t have much and alot of places recommended this but on every single snap iv tried to install even ones i know should work on arm devices like the raspberry pi i get this error: “error: cannot install “application”: snap not found” im kindof a linux noob so please explain it simply

can you name a few ?

if an application is built for the arm architecture is completely in the hands of the packager (you can select which architectures you want to build your snap on when packaging) …

often the snap packages are not 100% called like you would expect them so doing a snap find <appname> is sometimes helpful.

architectures a snap supports are listed in the menu next to the install button on the store webpage (i.e. see … if you unfold the pulldown menu next to “Install” there is another pulldown (typically saying amd64) if you find armhf in that list, the snap should be installable on a pi.

I used the same names as in the Debian repository(sudo snap install libreoffice, sudo snap install minetest etc.) at first I was trying to get Spotify but then I tried things that I know work on the pi like minetest and libreoffice

well, execpt for minetest the other snaps definitelydo not have an armhf build …

Oh well OK thx for helping