Error: system does not fully support snapd: cannot mount squashfs image using "squashfs": mount:

Hello everyone, I’m getting the following error when trying to install core on Debian 11 / bullseye

root@puppeteer:~# snap install core
error: system does not fully support snapd: cannot mount squashfs image using "squashfs": mount:
       /tmp/sanity-mountpoint-180662911: unknown filesystem type 'squashfs'.

I read through all the forum posts/stackover I could and nothing helped. Here is all the info I could gather. I would appreciate any help you could provided. I restarted the machine between and after every step.

root@puppeteer:~# snap --version
snap    2.49-1+deb11u1
snapd   2.49-1+deb11u1
series  16
debian  11
kernel  5.10.0-19-amd64

root@puppeteer:/tmp# snap download hello-world
Fetching snap "hello-world"
Fetching assertions for "hello-world"
Install the snap with:
   snap ack hello-world_29.assert
   snap install hello-world_29.snap
root@puppeteer:/tmp# mkdir snap-test
root@puppeteer:/tmp# mount hello-world*.snap snap-test
mount: /tmp/snap-test: unknown filesystem type 'squashfs'.

root@puppeteer:~# sestatus
-bash: sestatus: command not found

root@puppeteer:~# apt install libsquashfuse0 squashfuse fuse
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
fuse is already the newest version (2.9.9-5).
libsquashfuse0 is already the newest version (0.1.103-3).
squashfuse is already the newest version (0.1.103-3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@puppeteer:/tmp# grep squashfs /proc/filesystems

root@puppeteer:/tmp# journalctl -u snapd


When I run the following commands squashfs is not in them

cat /proc/filesystems

Unfortunately when I run this command nothing happens

modprobe squashfs

Just goes to the next line and nothing changes in the first commands even after a restart. Any ideas how to make this work?

System Info @

root@puppeteer:~# cat /proc/version
Linux version 5.10.0-19-amd64 ( (gcc-10 (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP Debian 5.10.149-2 (2022-10-21)
root@puppeteer:~# cat /etc/*-release
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION="11 (bullseye)"

Turns out there were lines in my /etc/modprobe.d/*.conf file that was preventing squashfs from being installed.