Error : snap "sosumi" has "remove-snap" change in progress

hi, i want to remove sosumi of my computer but when i ran the command, my computer crashed so now, i want to remove it but it says error : snap “sosumi” has “remove-snap” change in progress

pls help me !

Hi @freezilu .

Please, copy and paste the bug in this chat .

the bug is that the terminal said error : snap “sosumi” has “remove-snap” change in progress

~ @freezilu , what command did you execute ?

when it crashed, i ran sudo snap remove sosumi and now, when i run sudo snap remove --purge sosumi there is the error

~ @freezilu , sosuma does not available in the snap repository . I need to have the program for testing .

~ @freezilu , normally , when you execute the command sudo snap remove {your-package} , you do not need to purge the package (in many cases).

Some programs need a reboot to finalize some processes .

Any way, you can stop the background processes linked to the program sosuma by executing these commands :

snap changes (to get the id linked to your action snap remove sosuma)

sudo snap abort {the id of the operation}

Then :

sudo snap remove --purge sosumi

1 Like

thx it worked !

Okay ! Well @freezilu :+1:.