Error on Electron example


I’ve tried an snap for the electron example application the the help of the corresponding Snapcraft Live Video ( Unfortunately I ran into an error.

When running the npm run dist command, I get the following error:

> electron-quick-start@1.0.0 dist /home/peter/Schreibtisch/electron-quick-start
> build --linux snap

sh: 1: build: not found
npm ERR! syscall spawn
npm ERR! file sh
npm ERR! errno ENOENT
npm ERR! electron-quick-start@1.0.0 dist: `build --linux snap`
npm ERR! spawn ENOENT
npm ERR! 
npm ERR! Failed at the electron-quick-start@1.0.0 dist script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/peter/.npm/_logs/2020-01-05T06_38_40_699Z-debug.log

For creating the snap I’ve used a blank XUbuntu 19.10 installation within Virtualbox. I exactly followed the steps from the video…

Has anyone an idea what caused the error?

Thanks in advance, Peter

I get the same error on Ubuntu 18.04.

Has anyone any suggestions?

You need to change the following line in your package.json:

"dist": "build --linux snap"


"dist": "electron-builder --linux snap"

1 Like