Ensure prerequisites are available for remmina

Linux raspberrypi 4.14
Short version:
trying to reinstall remmina 1.2 and it just says
error: cannot perform the following tasks:

  • Ensure prerequisites for “remmina” are available (no snap revision available as specified)

Long version:
apt installed remmina, and it runs ok but it’s only 1.1
apt installed snapd, rebooted
snap installed remmina worked fine and it’s 1.2, but I couldn’t figure out how to run the snap version of remmina 1.2 instead of the apt 1.1 remmina
snap uninstall remmina worked ok
apt uninstall remmina worked too
now I know how to run snaps and I’m trying to reinstall remmina 1.2 but snap just keeps saying the error above. snap download/ack/install .snap also gives same error.

Do I apt install some prerequisite packages before snap installing remmina?

You can run snap run remmina in a terminal to specify running the snap version of remmina.

The only prerequisite package install via apt should be snapd

1 Like

Well that’s good to know.
But when i run snap install remmina I still get the prerequisites error.
I will try uninstalling and reinstalling snapd