Electronplayer snap stops working - no error


The snap electronplayer stopped working and when run via console it returns immediately without errors on the stdout. There is no error messages printed on dmesg/journalctl:
$ electronplayer
$ snap run electronplayer
$ /snap/bin/electronplayer

I know that the program ran yesterday (I’ve been using it for months). Digging into the sys logs I found that these are the only updates on my system since the last time the program was working:
gtk2-common-themes snap: rev 9 => rev 13
apt updates for libgjs0g:amd64 (1.64.2-1ubuntu1~20.04.1, 1.64.3-1~ubuntu20.04.1), gjs:amd64 (1.64.2-1ubuntu1~20.04.1, 1.64.3-1~ubuntu20.04.1)

System info:
$ snap version
snap 2.45
snapd 2.45
series 16
ubuntu 20.04
kernel 5.4.0-37-generic

$ snap list # filtered only relevant snaps
Name Version Rev Tracking Publisher Notes
core 16-2.45 9289 latest/stable canonical✓ core
core18 20200427 1754 latest/stable canonical✓ base
electronplayer 2.0.8 10 latest/beta oscartbeaumont jailmode
gnome-3-28-1804 3.28.0-17-gde3d74c.de3d74c 128 latest/stable canonical✓ -
gnome-3-34-1804 0+git.3009fc7 36 latest/stable/… canonical✓ -
gtk-common-themes 0.1-36-gc75f853 1506 latest/stable canonical✓ -
gtk2-common-themes 0.1 13 latest/stable canonical✓ -

All other snaps in my system work fine.

My concern is there are no error messages to start investigating. Any thoughts? Thanks!

I installed gt2-common-themes rev=9 but the problem persists. for libgjs0g and gjs I downgraded to an earlier version 1.64.1-2ubuntu1 but still no luck.

I found the problem. Turns out something deleted my ~/Templates folder and this in turn made the ~/snap/electronplayer/10/.config/user-dirs.dirs file to have a corrupted record:

Removing the record from the file causes the program to regenerate the record with the “correct” value:

It does not matter that the Directory does not exist in my system…

BTW it seems that many errors lead to snaps not starting without printing errors. I tried dropping the config as suggested here and once the problem was solved I repeated the process until I spotted the problematic file.

Not sure why no log files are generated but I wish there was a way to get more info on similar problems.