Downloaded image hash does not match

I can’t build after adding base: core18:

$ snapcraft --debug
Launching a VM.
launch failed: Downloaded image hash does not match
An error occurred when trying to launch the instance with ‘multipass’: returned exit code 2.
Ensure that ‘multipass’ is setup correctly and try again.

I searched for "Downloaded image hash does not match" and got no results.

I tried snapcraft clean and it didn’t work. I tried multipass list, multipass delete, and multipass stop, and it didn’t work. I tried rm -r ~/.local/share/snapcraft ~/snap/snapcraft ~/.cache/snapcraft but it didn’t work. rm -r ~/.local/share/multipass ~/snap/multipass also didn’t work. Removing the snapcraft prime and other generated directories in the project also didn’t work. multipass launch does succeed after a couple minutesbutsnapcraft --debug` still fails after that. I’m on 18.10.

I’m also seeing this on Ubuntu 19.04.

This seems to be an issue in the latest multipass (cc @Saviq and @townsend). This is what I see here:

$ multipass launch snapcraft:core18
launch failed: Downloaded image hash does not match                             

$ multipass --version
multipass  v0.5
multipassd v0.5

Reverting multipass seems to get things to work again:

$ sudo snap revert multipass
multipass reverted to 2018.12.1

$ multipass --version                 
multipass  2018.12.1
multipassd 2018.12.1

$ snap info multipass
installed:   2018.12.1            (572) 111MB classic

$ multipass launch snapcraft:core18
Launched: mighty-gryphon


Hmm, I’ll have to look at what may have changed between those beta releases as nothing obvious comes to mind.

BTW, this is

Hi, I just noticed that multipass with edge rev. can fix this issue as I also hit the case, thanks.

I just ran into this with the current edge channel version. But if I uninstalled and reinstalled the same version, solved the issue (at least for now).

edge:             v0.5-178-g05a27c5 2019-03-18 (679) 112MB classic

Just a FYI.

I ran into this issue on 20.04 trying to test building a patch to my snap that did work, and I was able to fix it by removing multipass with sudo snap remove --purge multipass and then running snapcraft again and when it asked to re-install multipass I said Yes and then it started working again.

There seems to be something happening when Multipass Snap updates between builds that prevents the signatures from being valid.

1 Like