Dotnet 3.1 problem - libc.musl not found


I installed dotnet 3.1 on OpenSUSE and Ubuntu with snap. Starting a self developed application I get the error

/snap/dotnet-sdk/95/dotnet: error while loading shared libraries: cannot open shared object file: No such file or directory

I get the exact same error on Ubuntu and OpenSUSE.

Starting the same application on Fedora, where I installed dotnet 3.1 with the Fedora package manager dnf it works flawless.

So I assume it is about my dotnet installation with snap. Does anyone know what the problem here is and how to fix it?
Thanks in advance and best regards

1 Like

Did you install dotnet-sdk, or dotnet-runtime-31? These are both created by Microsoft, so you might get better help by reporting to them via Can you share your application or simple reproduction steps so that we can try to replicate your situation?

@advocacy might be able to poke MS directly if there is an easy way to recreate the problem at whim.

I am experiencing the same. It seems to be a recent change that caused this. I am using Ubuntu 18.04.5 and also get the exact same error, whereas everything was working fine for months leading up to this.

Same problem on Ubuntu 20.04 — worked fine for months and then suddenly this problem.

I’m using snap install dotnet-sdk which gets me version 3.1.401, which is dated 8/11. So maybe it just updated and is causing a problem.

Update: Fixed via sudo snap revert dotnet-sdk — I’m sure it’s only temporary.

Try sudo snap revert dotnet-sdk to go back from 3.1.401 to 3.1.302.

Yeah, this appears to be an issue with the snap. We have tracking this problem on our side.

1 Like