Docker run hello-world docker is not working

I have tried on my laptop and also on an arm64 device, with the same result:

$ docker run hello-world docker
Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
0e03bdcc26d7: Pull complete 
Digest: sha256:6a65f928fb91fcfbc963f7aa6d57c8eeb426ad9a20c7ee045538ef34847f44f1
Status: Downloaded newer image for hello-world:latest
docker: Error response from daemon: OCI runtime create failed: container_linux.go:345: starting container process caused "exec: \"docker\": executable file not found in $PATH": unknown.
ERRO[0008] error waiting for container: context canceled

The version I have installed is:
installed: 18.09.9 (423) 126MB -

why do you have docker at the end of this? This also fails the same way for me, but removing that last line it works fine:

$ docker run hello-world

Hello from Docker!

Oops, my mistake - thanks for pointing out :slightly_smiling_face:

The error seemed so catastrophic that I thought something was really going south!

1 Like