Docker on ElementaryOS 5 can't access internet

I have a laptop running ElementaryOS 5, that I use for coding on the road. I mainly use a Windows VM ran by VirtualBox, but right now I am working in web app where I use some docker containers to provide apache, php & mongodb services, on my main dev machine (OSX).

A couple of days ago I decided to setup my laptop with the required environment to work with that project, so I cloned the repo, installed docker via snap and ran docker-compose up -d. Docker containers were built without problems, except that none of the containers are able to reach network outside, so I am not being able to download and install some required software on the containers.

I checked lots of solutions on the web, but none of them worked.

Anyone in the same situation? I even uninstalled docker from snap and tried to install it using apt-get, but it seems there isn’t a valid docker source for my SO version :frowning:


Victor Espina

@xnox any ideas ?

I just read about boot2docker… since I already have VirtualBox installed on that laptop, I may try creating a new VM to run boot2docker and try to create my containers from there… hopefully running my containers in the virtualized docker-friendly OS may work as a workaround to my problem.

I don’t use ElementaryOS nor do I know your configuration. Please use upstream docker setup guides, that have lots of information on the docker bridge and firewalls. By default, traffic is dropped, and plumbed through on container by container basis. But you also need to figure out what docker does and how it integrates with firewalls you may have enabled on your system. Installing multiple hypervisor and container solutions on a single host, and having own firewalls, can interact with each other in the unexpected ways.

As docker containers are up, the rest of networking troubleshooting is for you to figure out, as docker itself cannot detect all deployments or to punch firewalls correctly.