Disable ntp timesync all together

Hi, I have a module which is being affected by the time jumps happening when time is synchronized. To temporarily resolve this, I have chose to disable the time sync through “timedatectl set-ntp false”

If this is done on first boot and all other subsequent boots? Would this have any serious affect on registering device to serial vault or any such operations?