I am trying to install
snapd in RHEL 8 following the instructions available here but I have issues with the dependencies of
snapd-selinux that I am not able to resolve.
In regards to the instructions, I could add the EPEL repository but not the “ optional and extras repositories” with the proposed command. However, I added certain subscriptions (I read somewhere else that it was recommended to be subscribed to
codeready-builder). By asking for the
yum repolist, I can see that I am subscribed to:
sudo yum install snapd I get the error:
Problem: package snapd-2.49-2.el8.x86_64 requires snapd-selinux = 2.49-2.el8, but none of the providers can be installed
- conflicting requests
- nothing provides selinux-policy-base >= 3.14.3-54.el8_3.2 needed by snapd-selinux-2.49-2.el8.noarch
sudo rpm -aq | grep selinux shows me that I have older versions of SELinux-related packages:
Trying to upgrade
selinux-policy packages so I can install
snapd-selinux was impossible: I enter a rabbit hole of dependencies with conflicting requests (I can give more details if necessary, but I can say that trying
allowerasing didn‘t change the outcome).
I was wondering if there is a way to install an older version of
snapd in RHEL 8 so there is no conflict, and if so, which one would be a good candidate.
Thank you for any information you may provide!