Dependencies error when I run 'snapcraft'

Hello, i’m trying to build a new snap app trough snapcraft but I’m having some problems.

Yaml file

This is the content of yaml file, i removed the initial information part (name, version, etc…)

confinement: devmode
grade: stable
base: core18
    plugin: python
    python-version: python3
    source-tag: v1.0
    python-packages: [requests==2.25.1]

    command: /bin/ibop
    plugs: [network]

Python Code

In the repository used to upload the source code of the command i created the following files:

  • That consist in the python code of the command
  • requirements.txt


The problem is that when i run the command snapcraft i have the following error:

Looking in links: /root/parts/ibop/python-packages
Processing /root/parts/ibop/build
  Preparing metadata ( ... done
ERROR: No .egg-info directory found in /tmp/pip-pip-egg-info-pe2aksjb
Not all dependencies where satisfied with python-packages or requirements. Resorting to fetching from PyPI.

Hi. The file is typically used to create the package for your app, but yours has standard Python code. What is your intention here exactly?