Dell gw5000 snap


I am not able to refresh snap on by dell gw 5000 here is the os version I am using

VERSION=“16.04.1 LTS (Xenial Xerus)”
PRETTY_NAME=“Ubuntu 16.04.1 LTS”

I am getting following error when I am trying to refresh
" ERROR received an unexpected http response code (404) when trying to download "

Most surely is this (transient) problem: a new version was released for that snap, but still not verified, and (because of a bug) we’re failing to serve it properly.

Bug is recorded here:

It’s already fixed, but still not in production (will be rolled out first days next week)

Hi Facundo,

Thanks for the reply we will be waiting till next week, is their any way to install snap classic

Hi Facundo,

Do we have any update on this ?

The latest core snap in stable hasn’t yet been validated for the Gateway 5000. It’s expected that this will happen first thing tomorrow. As Facundo mentioned, there’s a bug that’s being worked on which causes the error message when snapd tries to download an older version of a snap that is no longer published in an accessible channel. Once the latest stable core snap is validated for the hardware, the error will no longer happen and the core snap will be refreshed.

If you’d like to install now, you can do so using this command:

$ snap refresh core --ignore-validation


Facundo’s fix for this was rolled out a few minutes ago, so these devices should now happily update to the most recent, validated revision (which may not necessarily be the latest uploaded) . Could you please check and let me know if things are OK now?


  • Daniel
1 Like

Hi ,

Thanks it is working fine now can I update to snap 2.33 ?

I think you are mixing up version numbers for snapcraft (the tool used to create snap packages) and snap/snapd (the daemon and cli that manages the system).

The latest release of snapcraft is 2.33

The latest core snap on the stable channel for Gateway 5000 should bring you snap/snapd versions 2.26.14