Define apt repository for snapcraft (configuration)


#1

Hi,

My OS is Ubuntu Cosmic 18.10 and i want to do a snap with smartcraft (with core18).

But i have many warnings before generate snap due to snapcraft try to get stage-packages from 18.10 apt repository instead of 18.04 (core18 = 18.04 version). Libc6 (define by core18) of my target is to old for sevral new libraries of 18.10.

So, if it possible to configure Snapcraft to use 18.04 apt repository instead of 18.10 of my OS

Thanks !

The GLIBC version of the targeted core is 2.27. A newer libc will be required for the following files:

/home/stan/mysnaps/caprice32/prime/usr/lib/x86_64-linux-gnu/libdrm_amdgpu.so.1.0.0 (requires GLIBC 2.28)
warning: working around a Linux kernel bug by creating a hole of 4096 bytes in ‘/tmp/tmpnq0voei3’
warning: working around a Linux kernel bug by creating a hole of 8192 bytes in ‘/tmp/tmp5q82_l8m’
warning: working around a Linux kernel bug by creating a hole of 4096 bytes in ‘/tmp/tmpqvqpbun6’
warning: working around a Linux kernel bug by creating a hole of 319488 bytes in ‘/tmp/tmpn7daidfq’
warning: working around a Linux kernel bug by creating a hole of 4096 bytes in ‘/tmp/tmpc_yk3_1z’
Priming launcher
Snapping ‘caprice32’ |
Snapped caprice32_4.5.0_amd64.snap

PS : i have exactly same issue with core (16.04), and i can’t use VM because my multipass crash with my CPU.