Debug PMS Video Optimization feature

Running Snap Plex Media Server Version on Ubuntu 22.04

I am trying to get the Version Optimization to work but I keep getting a vague unclear error:

unable to convert

My media library is located on


Due to limited space on my main SSD, I moved the ‘Plex Media Server’ folder to a different location on its own SSD:


using the following:

sudo cp -a /var/snap/plexmediaserver/common/Library/‘Application Support’/‘Plex Media Server’/. /media/plex/‘Plex Media Server’

sudo rm -rf /var/snap/plexmediaserver/common/Library/‘Application Support’/‘Plex Media Server’

sudo ln -s /media/plex/‘Plex Media Server’ /var/snap/plexmediaserver/common/Library/‘Application Support’/

This seem to work just fine and I am not getting any errors after doing that. I also created the Directory


with a subfolder for each of the libraries and I set the ownership to root so Snap Plex can read and write to those directories. That solved the error of " unable to write to disk" when using this directory to save the optimized versions.

The console tap in Plex is not showing me any errors so I have no idea how to start figuring out the source of the problem. Has anyone been in a similar situation? Your help is much appreciated.

Unable to convert Media

Settings for the Transcoder

Edit: The console tap in Plex is showing me an error:

[Transcoder] Unrecognized option ‘crf:0’. [Transcoder] Error splitting the argument list: Option not found

I had two windows open next to each other where i tried transcoding in one and observed the console on the other.

I’m having what sounds like the same issues. I have to set the target directory permissions 777 to make it work, which is rather annoying. Then to modify or delete anything it creates I have to set it all to 777. I have resorted to using Handbrake instead, but it’s making me want to switch to Docker and ditch snap.

1 Like

I switched to the apt release of Plex. start by making a backup of 'Plex Media Server', even when it is on a diffrent SSD like in my case. the next steps are based on this guid.

After removing Plex Snap, run thos commands:

curl | sudo apt-key add -

echo deb public main | sudo tee /etc/apt/sources.list.d/plexmediaserver.list

sudo apt update

sudo apt install plexmediaserver

to stop the server:

sudo systemctl stop plexmediaserver

remove ‘Plex Media Server’ folder from the apt install and then replace it with your backup.

sudo rm -rf /var/lib/plexmediaserver/Library/'Application Support'/'Plex Media Server'

before moving or creating shortcuts, make sure to change the ownership of the Folder to Plex

sudo chown -R plex:plex /media/plex/'Plex Media Server'

personally, I have the folder on its own SSD, so all i need is to create a shortcut to the correct location:

sudo ln -s /media/plex/'Plex Media Server' /var/lib/plexmediaserver/Library/'Application Support'/

Check the ownership of folders, subfolders and shortcuts that all belong to Plex using the command ls -l, then try and start the service once everything is ok:

sudo systemctl start plexmediaserver

it should pick up right where you left off. and now hardware acceleration should work smoothly.

while it is great that you found a solution for yourself, it would be nice to report it in the right place at the plex support forum in the server-snap category so the maintainers know about it and can actually fix it for the rest of the world :slight_smile:

1 Like

I have already done that… it seems that Plex Snap cannot support hardware acceleration due to the way the app is packaged. For this reason the most suitable solution is to use the .deb release or the apt release to take full advantage of the hardware and avoid such errors.

well, snapd provides all graphics related host libraries in /var/lib/snapd/lib/gl to the application snaps, if your host has the correct VAAPI or VDPAU libs installed they should be available in that dir … this is a matter of doing the packaging right :wink:

Hardware acceleration works with plex snap, but you need plex pass.