Db410c : memory_stress_ng not able to run


how can i run the memory_stress_ng without using swap space? since we do not have swap space it is not possible to run?

When i run memory_stress_ng job , it says
Swap space unavailable! Please activate swap space and re-run this test!

to enable a swap file on ubuntu-core you can edit /etc/default/swapfile and add a value to the SIZE variable, that should create /var/tmp/swapfile.swp on next reboot.

added 1GB to the file /etc/default/swapfile , but after reboot it did not create any swapfile.

but i was able to manage by manual create a swapfile and test the memtest.
$dd if=/dev/zero of=/home/vinaysimha/.swapfile bs=1024 count=524288
$mkswap /home/vinaysimha/.swapfile
$sudo swapon /home/vinaysimha/.swapfile

vinaysimha@localhost:~$ swapon -s
Filename Type Size Used Priority
/home/vinaysimha/.swapfile file 524284 0 -1

oops, you might need to enable the systemd unit with:

sudo systemctl enable swapfile
sudo systemctl start swapfile

even these two commands did not worked without reboot, with reboot also. do i am still missing something?

vinaysimha@localhost:~$ more /etc/default/swapfile

no, this should definitely just work … i’ll take a look