Cross Compiling armhf; stage-packages


#1

Hello,

Host info: Ubuntu 16.04, snapcraft 2.42.1

Trying to cross-compile a go application for armhf which has a few dependent packages.

I’ve defined architectures : [armhf] and I’ve also tried passing in --target-arch=armhf to snapcraft.

I’ve tried defining stage-packages as package:armhf and as package on armhf.

I’ve tried setting dpkg --add-architecture armhf, and I’ve added, deb [arch=armhf] http://ports.ubuntu.com/ubuntu-ports xenial main universe to /etc/apt/sources.list

But still the armhf packages are not being pulled during stage.

Any ideas? Suggestions?


#2

I don’t think cross compiling is fully functional at this point, I encountered similar issues and could not get around it. Right now I am compiling natively on a Raspberry Pi for my ARM builds.


#3

Hi, I responded to your other post here: Stage-Packages with --target-arch

(in case anyone else happens upon this problem and hits this page)

Thanks,
Ian


#4

Hi;

Are you using Snapcraft for building natively on RPi?

Thanks,
Vahid


#5

Yes, I am using the Ubuntu 16.04 image on a Raspberry Pi 3 to compile my armhf snap.


#6

Could you kindly send me a complete guide for that? I have some difficulties.

Thanks in advance.

Vahid


#7

See this guide for install Ubuntu on RPi: https://wiki.ubuntu.com/ARM/RaspberryPi

Then it’s just a matter of installing snapcraft from apt and running it.