Creating a snap for ubuntu-make


#1

@kalikiana It’s still not working in the umake snap…
Maybe there’s something to change in the yaml or in the wrapper?
If somebody could look at it they’re here:


Classic snaps failing on Ubuntu 17.10
#2

I took a look at your snapcraft.yaml. I would be surprised if it worked on 14.04 too. If the hurry is too great, you could go down the path of compiling your own python as we currenly do in snapcraft and conjure-up which are also classic snaps, but this is not a quick fix and a lot of testing will be required before we release after the fix lands.


#3

Thanks @sergiusens
At the moment it works in all but 17.10.
I’m looking at the snapcraft yaml now, since umake needs to use apt (like snapcraft)
The process of adding the libc stuff was done by @didrocks to make it work in 14.04


#4

@sergiusens
I’m trying to rebuild the umake snap like the snapcraft one…
But I get the following error:
ModuleNotFoundError: No module named 'apt’
I added in the requirements.txt the following line, copied from the snapcraft one:

https://launchpad.net/ubuntu/+archive/primary/+files/python-apt_1.1.0~beta1build1.tar.xz; sys_platform == ‘linux’

Is that correct?


#5

Can we create a new topic for this so people following the subject for the specific work we decided to do are not overwhelmed?


#6

Hi.
I’m still having issues building the ubuntu-make snap.
As it is now, it only works if I remove the LD_LIBRARY_PATH export in the custom launcher.
But that is needed for the snap to use the libraries from the snap itself.
Is there a different way to do this? I see it’s been removed from the snapcraft snap


#7

Moved that topic here, as it’s an independent conversation from the points we were covering on the original topic.


#8

Thanks @niemeyer. I wasn’t sure how to split the discussion.
I’d still need a hand to figure out what I need to change.
I tested adding only the $SNAP/usr/lib and $SNAP/usr/lib/$ARCH.
That made it work in 17.10, but not in 14.04…