Corebird and wayland issues


#1

I have recently setup a new install with Ubuntu 17.10 beta2 and just stuck with the defaults, which means I am now running wayland, this affects corebird as this is what I get when running it:

sergiusens  ~  corebird 

(corebird:22962): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.

(corebird:22962): Gtk-WARNING **: cannot open display: :0

If I sort of force xwayland on it with a bogus WAYLAND_DISPLAY entry it works:

 sergiusens  ~  WAYLAND_DISPLAY=asadf corebird

(corebird:22984): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(corebird:22984): Gtk-WARNING **: Theme parsing error: style.css:20:13: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(corebird:22984): Gtk-WARNING **: Theme parsing error: style.css:230:16: The 'outline-radius' property has been renamed to '-gtk-outline-radius'

(corebird:22984): Gtk-WARNING **: Theme parsing error: style.css:236:19: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(corebird:22984): Gtk-WARNING **: Theme parsing error: style.css:237:25: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(corebird:22984): Gtk-WARNING **: Theme parsing error: style.css:242:36: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(corebird:22984): Gdk-CRITICAL **: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed

(corebird:22984): corebird-WARNING **: MainWindow.vala:492: Couldn't load window geometry for screen_name `sergiusens'

What would be the proper way to fix this?


#2

While I don’t know the solution, I’d like to know whether this is something I’ve missed in creating the snap configuration, or if this is a more general snap+wayland issue which is more far-reaching than just the corebird snap.


#3

Are you plugging the new wayland interface? If so, are you using the desktop launcher? Are there security policy denials in journalctl?

Because of the current setup of XDG_RUNTIME_DIR, today you need to use the wayland interface and set up a compatibility symlink for wayland to work (something the desktop launcher is doing. This is not ideal and the idea is to fix it when we have per-user mounts.


#4

no, I’m not plugging wayland interface. Other snaps like irccloud-desktop do not do that and work fine.


#5

If you want to use wayland, you need to do as I said. If you want to just use Xwayland, then the issue is something else. Perhaps @kenvandine would have some insight.


#6

can you try the version in edge - that build now plugs the wayland interface, and also updates to use the new gnome-3-26-1604 snap and it’s content interface


#7

Corebird 1.7.1 is released, can we have an update?


#8

please don’t hijack threads :slight_smile: to answer your question, I’m working on it. If you want to discuss details about the new release can I ask that you start a new thread with your thoughts so that we don’t talk cross-purposes?


#9

Sorry, i was thinking about that


#11

I experience the very same “Gtk-WARNING **: cannot open display: :0” with other snaps I have tried. Apart from corebird I also tested gradio and peek, all have the same issue. The hack with setting WAYLAND_DISPLAY to a bogus value works.

Now the interesting thing: I switched over to an Xorg session (Ubuntu on Xorg, XDG_SESSION_TYPE is set to x11), but I encounter the very same issue. And the same workaround fixes it. I am puzzled.


#12

What corebird, peek and gradio have in common is that they all use the gnome platform snap. Only gradio uses the older gnome-3-24-platform, the other two gnome-3-26-1604


#13

Latest corebird from edge with wayland plug works for me also inside the wayland session. This also seems to fix peek.

This also got a bit clearer. A reboot and login directly into X11 fixed that. But logging out of the session, switching to Wayland (which shows the issue), then logging out again and back into X11 brings the session back also in X11. env shows nothing wayland related there, WAYLAND_DISPLAY is not set. Seems like session switching leaves something (?) around. Anyway, unrelated issue.


#14

I had the same problem with Gradio. Solution for me:

Upgrade from GNOME 3.24 to 3.26
Add “wayland” to “plugs”

Gradio snapcraft.yaml: https://github.com/haecker-felix/gradio-snap/blob/master/snap/snapcraft.yaml
Issue: https://github.com/haecker-felix/gradio/issues/245

I don’t want to hijack this thread, but it would be nice, if the plugs get connected automatically:

sudo snap connect gradio:gnome-3-24-platform gnome-3-24:gnome-3-24-platform

People can’t install Gradio without using the terminal. I think this is a big disadvantage of snap (in comparsion to flatpak).


#15

@haeckerfelix - the gnome-3-26-1604 snap is autoconnected:

$ sudo snap install gnome-3-26-1604
$ sudo snap install gradio
$ snap interfaces
...
gnome-3-26-1604:gnome-3-26-1604  gradio
...

Your command is connecting the gnome-3-24-platform snap which isn’t supposed to autoconnect.