"Contact <snap owner>" for element-client snap uses bad email

Hey folks,

I was setting up a matrix client recently and installed element-client instead of element-desktop. When troubleshooting the element-client, I was told by Ken to use element-desktop instead (which works). After switching to resolve my issues, I tried to contact the owner of element-client to let them know that their snap doesn’t work and folks should use element-desktop instead. I suggested that he should unregister the element-client name if he’s not maintaining it (which is fine and it happens), to avoid confusion by another unsuspecting user. However, the email address attached to the “Contact Arnaud Lier” returns as non-existant:

[<arnaud@eclixo.com>](mailto:arnaud@eclixo.com): Host or domain name not found. Name service error for name=eclixo.com type=MX: Host not found, try again

Is there another way to contact a missing developer? Or would it be possible to just hide this snap from searches so folks don’t hit this non-working snap issue?

Thanks for reporting this. Since the packager is entirely unreachable, I have made the snap private for now (not only unsearchable but also uninstallable by anyone other than the publisher - which makes sense if the snap is entirely broken). Should the publisher show up again, they can make the snap visible directly, and hopefully fix it.

I think that’s the best we can do for now since we have absolutely no other way to contact them :confused:

  • Daniel

Hey thanks so much!! I gave it about 30 min and then searched for “element” and I see it’s still showing up. @roadmr could you double check that you hid it?

The “Element” snap listed actually takes you to the “element-client” snap.

The web frontend’s cache is very sticky. Try busting it with an extra query parameter. The API is doing the right thing:

$ curl -s "https://api.snapcraft.io/v2/snaps/info/element-client" -H "Snap-Device-Series: 16" -H "Snap-Device-Architecture: amd64" | jq .
  "error-list": [
      "code": "resource-not-found",
      "message": "No snap named 'element-client' found in series '16'."

$ curl -s "https://api.snapcraft.io/v2/snaps/find?q=element-client" -H "Snap-Device-Series: 16" -H "Snap-Device-Architecture: amd64" | jq .
  "results": []
$ curl -s "https://api.snapcraft.io/v2/snaps/find?q=element" -H "Snap-Device-Series: 16" -H "Snap-Device-Architecture: amd64" | jq '.results[]|select(.name=="element-client")'

I searched for “element-client” and saw it was missing. Then I tried searching for “element” and only Ken’s element-desktop shows up now. So whatever caused the frontend cache to reset worked :woman_shrugging: