Compatibility issues running snaps under Fedora 29


#1

Just tried out several of my snaps under Fedora 29 Workstation, the results are quite disappointing:

snap identifier snap type test results
gallery-dl core18, command-line interface, python working :slight_smile:
guvcview legacy core18
desktop-gtk3 helper desktop-gnome-platform
gtk-common-themes
(wayland) segfaults execl failed at possibly snap-exec
(xorg) Failed with cannot open display: :0 (functional after full reboot) execl failed at possibly snap-exec
hello-snapcrafters legacy, command-line interface working :slight_smile:
love core18, gui, no-desktop-helper execl failed at possibly snap-exec
mari0 core18, gui, no-desktop-helper execl failed at possibly snap-exec
my-awesome-app legacy core18
desktop-gtk3 desktop-gnome-platform
gtk-common-themes
(wayland) segfaults works :slight_smile:
(xorg) Failed with cannot open display: :0 (functional after full reboot)
open-syobon-action core18, gui, no-desktop-helper, sdl working :slight_smile:

The Fedora instance runs in a QEMU/KVM virtual machine, via GNOME Boxes, all system updates installed. Wayland session is used by default.


#2

I will look into those. Wayland is curious but perhaps something can be fixed in general.

CC @mborzecki

EDIT: what was the version of snapd you were using? Is it fully up-to-date F29?


#3

Some testing on Arch:

  1. mari0 seems to work fine on with Xorg an wayland
  2. guvcview works fine with Xorg, with wayland zenity segfaults when attempting to show a message box
  3. my-awesome-app Xorg fine, wayland segfault
  4. love-brlin, Xorg fine, wayland fine

#4
$ snap version
snap    2.37.4-2.fc29
snapd   2.37.4-2.fc29
series  16
fedora  29
kernel  4.20.14-200.fc29.x86_64

According to dnf upgrade, yes.


#5

I noticed that this error vanished after a full reboot, the my-awsome-app.my-app-name application can be launched normally then in an X.org session (Wayland still segfaults)


#6

I noticed that after migrating my-awesome-app to core18 base and gnome-3-28-1804 runtime the application no longer segfaults in the Wayland session:


#7

Any update regarding this issue, all my wine snaps are broken on f29 as well user reported this issue, I can reproduce it as well on freshly updated f29 vm setup.

execl failed: No such file or directory
child exited with status 1

#8

/cc @Conan_Kudo Would you shed some light on this topic?


#9

I have make this topic wiki, feel free to add your test results.


#10

Note that Solus seems to have solved the execl failed problem: https://dev.getsol.us/R3609:5fd02a7c03eca0f53aa389a701385558cf7fd423


#11

I can’t seem to reproduce this, neither using 2.37.4, nor with 2.38 from updates-testing.

Can you provide the output of snap version and rpm -qa snap\* ?

Also please try SNAPD_DEBUG=1 SNAP_CONFINE_DEBUG=1 snap run <failing-snap-app> and upload the log.


#12
  • snap version
snap    2.37.4-2.fc29
snapd   2.37.4-2.fc29
series  16
fedora  29
kernel  5.0.6-200.fc29.x86_64
  • rpm -qa snap*
snapd-glib-1.44-1.fc29.x86_64
snapd-selinux-2.37.4-2.fc29.noarch
snappy-1.1.7-8.fc29.x86_64
snapd-2.37.4-2.fc29.x86_64
snap-confine-2.37.4-2.fc29.x86_64

  • snap log

debug log


#13

Thanks, I was able to reproduce the problem with notepad-plus-plus snap. This looks like a problem:

[pid  4565] access("/usr/lib/snapd/snap-device-helper", X_OK) = 0
[pid  4565] execve("/usr/lib/snapd/snap-device-helper", ["/usr/lib/snapd/snap-device-helpe"..., "add", "snap_notepad-plus-plus_notepad-p"..., "/sys/class/mem/null", "1:3"], 0x7ffd0dce6418 /* 0 vars */) = -1 ENOENT (No such file or directory)
[pid  4565] write(2, "execl failed", 12execl failed) = 12
[pid  4565] write(2, ": No such file or directory\n", 28: No such file or directory

#14

Thank you for reporting this. I have transformed this into a bug here https://bugs.launchpad.net/snapd/+bug/1824158


#15

In the future, please file bugs in Red Hat Bugzilla. I can’t keep track of everything, and my ability to subscribe to topics and log into this forum was broken until very recently. Unless a bug is mirrored into Red Hat Bugzilla or filed there, I will not know about it!

I’ve fixed the issue with the snapd-2.39 update, which I just proposed earlier today (see the Fedora updates topic).