Client unable to be setup with air gapped snap store

I’m having trouble connecting my first client to my air gapped snap store. I am following the instructions from the ubuntu doc’s site (but I am having an issue due to being a new user and posting urls)

I have successfully registered my store and included a few snaps to use for testing.

When I run… curl -sL | sudo snap ack /dev/stdin I get an error “error: cannot assert: cannot decode request body into assertions: unexpected EOF” When I view in the browser I get: { “error-list”: [ { “code”: null, “message”: “Missing required query parameter ‘store_id’.” } ] }

If I run… curl -sL | sudo snap ack /dev/stdin Gives nothing back, but appears to run correctly. If I attempt to go to this url in the browser, I get ERR_CONNECTION_REFUSED. Maybe this is expected.

I then run: snap set core error: cannot perform the following tasks:

  • Run configure hook of “core” snap (run hook “configure”: cannot set to “exampleStoreID” without a matching store assertion) I am copying and pasting my store ID when I enter the command above.

snap-proxy status output: Store URL: Removed Store DB: ok Store is in device authenticated air-gapped mode Store ID: exampleStoreID Custom local stores: none Local account keys: Account ID Name Public Key SHA3-384 generic models d-JcZF9nD9eBw7bwMnH61x-bklnQOhQud1Is6o_cn2wTj8EYDi9musrIT9z2MdAa generic serials wrfougkz3Huq2T_KklfnufCC0HzG7bJ9wP99GV0FF-D3QH3eJtuSRlQc2JhrAoh1 Internal Service Status: memcached: running nginx: running packagereview: running packagereview-worker: running publishergw: running snapassert: running snapauth: running snapdevicegw: running snapdevicegw-local: running snapident: running snapproxy: running snaprevs: running snapstorage: running

Any ideas what may be wrong or how to fix?

While I’m not certain what was causing this. Starting over on a new server that had no software installed fixed the issue.