Classic confinement for dbeaverapp

dbeaverapp lacks permissions to open third party packages. There is a problem with opening the web browser, the application just crashes with an error

Start Browser Support [org.eclipse.ui.browser 3.6.1100.v20210118-1327] SWT WebKitGDBus: error creating DBus server Error binding to address: Permission denied SWT WebKit: error initializing DBus server, dBusServer == 0

Also there is a similar problem with opening office files. The office cannot be opened from the dbeaverapp snap package (any application that supports xlsx file). Tried changing the temporary directory for the generated file, but the problem was not resolved. I installed all the missing interfaces that the snappy-debug showed.

Application uses native gtk calls from eclipse.

Everything should work on the same principle as the eclipse package, but there are not enough permissions. Please, help :pensive:

1 Like

Since dbeaverapp is an IDE this fits within the supported categories for classic confinement, as such the requirements for classic confinement are understood. @advocacy can you please perform publisher vetting?

@riednyko What is the official site for dbeaverapp please?

Thanks for the answer!
The official dbeaver site:

And dbeaverapp is a test snap package. If everything works out, then after that we need the same thing for the official dbeaver-ce package

Hello! So what about the request?

@Igor ping, could you please check the provided information? Thanks!

@riednyko Sorry, I missed your reply completely. Apologies for that. Will perform the vetting now.

+1 from me, I verified the publisher.

Granting use of classic. This is now live.

1 Like

Thanks! Everything works now. Can you do the same with the dbeaver-ce snap package, please?

The official dbeaver site: