Chromium's crashpad isn't able to trace process crash

Hello. I use Electron framework for my application. Some time ago I faced with problem with receiving processes crash dumps. Investigations showed that the reason is that crashpad isn’t able to use ptrace api, to trace crashed process. ptrace: operation not permitted Only way I found is build my snap with ‘classic’ confinement, but I’am sure that it is excessive. I ask to suggest a way how to allow the use of ptrace without switching to ‘classic’ Thanks a lot.

As always, did you try using snappy-debug ?

i think switching the snap temporary to --devmode locally should grant you access to ptrace (not 100% sure though) … so in case you need debug info from users you could ask them to do this … i dont think our security team would be keen to actually grant ptrace beyond this since it might be possible to use it as an escape hatch from the sandbox …

Nope. I’ll try, thanks!

I tried with snappy-debug, but I did not found anything new for me:

= Seccomp =

Time: Jul 12 15:47:20

Log: auid=1000 uid=1000 gid=1000 ses=1 subj=snap.tradingview.tradingview pid=4346 comm="chrome_crashpad" exe="/snap/tradingview/39/chrome_crashpad_handler" sig=0 arch=c000003e 101(ptrace) compat=0 ip=0x7f3e6cb41923 code=0x50000

Syscall: ptrace

But, I tested my oldest app version, and dump works there! (tried not so old before), so I conclude that it is a chromium issue. Maybe they broke setting relations between chrashpad process and renderer processes with prctl(). So, this topic is’t relevant anymore.