Certain apps won't open

Hi all,

Had the similar issue, some snap apps could run only for the first time after reinstalling.

In my case the isssue was with Documents link poinitng at another directory inside my OneDrive dir.

Was able to run them once removed that link and used bind mount instead.

Hope this will help.


Found a possible solution to this problem in this thread:

Basically, if you have any cross-filesystem symlinks, apparmor doesn’t like that and so you need to replace them with “bind mounts” that you set up in /etc/fstab.

Worked for me after having problems with getting authy to run on Ubuntu and Fedora after the first run.

This worked for me,too. I did have some links into my owncloud directory.

Thank you for the fix. But I think this shouĺd be resolved in snap or in the application. I find it unacceptable that I canot use softlinks in my home directory when using some random choice of apps.

Disconnecting the home plug worked for me, too. I removed bitwarden:home and that worked.

Just can’t help but wonder if there’ll be downsides, but I guess I’ll update this post if I find something.

Hopefully this issue will be resolved without that workaround.

1 Like