CentOS 8 snapd installation selinux

Hi all, i’m trying to install snapd on my CentOS 8 but I always get the error of

Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Last metadata expiration check: 0:18:02 ago on Fri 10 Jan 2020 10:18:50 AM WITA.
Problem: package snapd-2.42.2-1.el8.x86_64 requires snapd-selinux = 2.42.2-1.el8, but none of the providers can be installed

  • conflicting requests
  • nothing provides selinux-policy-base >= 3.14.3-20.el8 needed by snapd-selinux-2.42.2-1.el8.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

In the repo subscription, i tried to register via subscription manager to get the selinux, but it keep doing this:

Registering to: subscription.rhsm.redhat.com:443/subscription
Username: mbk1people
Unable to verify server’s identity: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:877)

How this issue can be solved? Thank you beforehand

Unfortunately, there’s not much snapd project can do. I’ve explained this in more detail right here:

It should be possible to install snapd on a RHEL8 system though.

Then it the required package actually already done, but not in the repo yet? I can’t download it manually from the site https://koji.mbox.centos.org/koji/buildinfo?buildID=5028 it is forbidden. Do I still need to register on the RHEL8 ( subscription.rhsm.redhat.com:443/subscription) ? #beginnerquestions

Someone filed a bug with incorrect category back in November. I’ve cloned it to a proper category right here: https://bugs.centos.org/view.php?id=16914 Please try to reach out to the maintainers in that ticket.

AFAIK there’s no reason to use to use RH subscription on non-RHEL, but I don’t know your use case, so perhaps it a question better suited for CentOS forums.

https://bugs.centos.org/view.php?id=16914#c36002 is now marked as resolved. The solution is to enable the continuous release (CR) repository since it contains the upcoming 8.1 packages.

You also need to ensure the squashfs module is available by installing kernel-modules package.

Hi all, i’m trying to install snapd on my CentOS 8 and i got the same error of this topic:

Problem: conflicting requests

  • nothing provides selinux-policy >= 3.14.3-95.el8 needed by snapd-selinux-2.56.2-1.el8.noarch
  • nothing provides selinux-policy-base >= 3.14.3-95.el8 needed by snapd-selinux-2.56.2-1.el8.noarch

I tried to enable CR Repository as suggested

sudo dnf config-manager --enable cr

sudo dnf repolist
id repo                                       name repo
appstream                                     CentOS Linux 8 - AppStream
baseos                                        CentOS Linux 8 - BaseOS
cr                                            CentOS Linux 8 - ContinuousRelease
epel                                          Extra Packages for Enterprise Linux 8 - x86_64
epel-modular                                  Extra Packages for Enterprise Linux Modular 8 - x86_64
extras                                        CentOS Linux 8 - Extras

and i checked kernel-module is installed

sudo yum list --installed | grep kernel-modules
kernel-modules.x86_64                         4.18.0-240.10.1.el8_3                             @anaconda 
kernel-modules.x86_64                         4.18.0-348.7.1.el8_5                              @baseos   

Why can’t i still install snapd?

Thank you beforehand